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Chapter 

1 
What Is NoteFiler? 

Overview 

NoteFiler is a program that will help you organize information. It will allow you to enter important 

information into your computer and then find it again very quickly. You enter the information into your 

computer using the familiar file cabinet as a metaphor. The database is made up of the drawers, folders 

and items. 

What does this mean to you? Well, you will now be able to locate all those things that used to elude you. 

NoteFiler can be used to organize your filing cabinet, song's, videos, recipes, books, family tree 

(genealogy) and much, much more. 

A Hierarchy for your Data 

Unlike competing programs, NoteFiler gives you the ability to organize your information into a logical 

hierarchy. Not only is it easy to setup a hierarchy in NoteFiler, it is easy to change the hierarchy if you 

should change your mind on what the best hierarchy is. The ability to arrange your data in a logical 

hierarchy is a key advantage that not only lets you find stored data quickly by drilling down the 

hierarchy, but also allows you to create reports that present your information in an intelligent and 

understandable way. 

Easy and Elegant Reports 

NoteFiler allows you to easily generate reports of the data that you’ve stored and gives you a tremendous 

amount of flexibility over how the reports will look allowing you to create truly elegant reports. With 

NoteFiler’s reports you can keep a list of all your videos in your family room end table a list of your 

favorite recipes in a kitchen drawer and a list of your books in your library. 

Example Databases 

In order to help you get started and to give you a few ideas on how to use NoteFiler, we have included 

several example databases. One of them contains examples of how to enter your CD's, VCR tapes, 

albums and cassettes into a NoteFiler database. Another contains an example of how to enter your 

home's inventory into a NoteFiler database. The example databases are intended only as a starting point 

and example. You may use them as is or use your own scheme for managing that information. The 

example databases are discussed in Appendix D Example Databases. 

Example Templates 

Templates are a powerful new feature of NoteFiler that all you to specify fields within the Contents of a 

NoteFiler article. For example, if you’re storing information on your daily running, you may wish to 

define fields for how far you ran, the amount of time it took you to run, what the weather was like 

(temperature, humidity, etc), and how you felt during the run. Maybe even a place to enter the pace at 

which you ran the course. Templates let you do this. In order to help you understand templates and get 
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started using them we’ve included several example templates which you can use as-is or modify for your 

own personal needs. These example templates are listed and explained in Appendix E Example 

Templates. 

Tips for Upgraders 

If you are upgrading from a version of Filer, you should read the section of Chapter 16 on Importing 

Data from Another Program describes how to import your Filer 2.1 databases so that you can use them 

with NoteFiler. You will find that NoteFiler has many improvements over Filer 2.1 including enhanced 

reports, an additional hierarchy level, the ability to easily copy or move articles and their children to 

another place in the database, the ability to define fields in the Contents editor by using Templates and 

more. Be absolutely sure to read Chapter 2 What’s New so that you know what new abilities you have to 

work with. 

Tips for New Users 

1. The tutorial takes you through basics of creating and using a NoteFiler database. You should 

read and perform the entire tutorial. 

2. Although you don’t have to use them, you should read about and understand templates since 

they provide significant enhancements to NoteFiler Contents. If you don’t know what they are, 

what they do, and how they improve the organization of your information, you will never be able 

to take advantage of them. There is a good likelihood that you will want to use templates if you 

understand them. 

3. Get to know all of the methods that are available to select and manipulate articles. In particular, 

you should read about and understand the Copy To and Move To commands. 
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Chapter 

2 
What’s New? 

Overview 

NoteFiler is a new product that replaces our previously sold Filer program. It is a major upgrade to 

Filer. Certainly there are many new features, but the enhancements don’t stop there. Many of the 

existing features have been refined and extended. Here are a few highlights: 

Four Level Hierarchy 

Filer had three levels of hierarchy. You now have four. 

Formatted Text in Contents 

NoteFiler Contents Editor now supports many of the formatting abilities of a word processor. You can 

now manipulate text in these ways: 

Character Styles 

 Bold 

 Italic 

 Underline 

 Strikeout 

Paragraph Properties 

 Left Justify 

 Right Justify 

 Center Justify 

 Left Indent 

 Right Indent 

 Hanging Indent 

 Bullets 

Font Properties 

 Font Name 

 Font Size 

 Font Color 

 Superscript 

 Subscript 
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Highly Configurable Reports 

NoteFiler now allows you to specify attributes for each level of your database’s hierarchy. You can 

specify the following attributes: 

For Labels (individually for Cabinets, Drawers, Folders, and Items) 

 Font 

 Font Size 

 Character Style: (Bold, Italic, Underline) 

 Space Before 

 Space After 

 Indent 

 Page Break (Never, Always, If prior article has Contents) 

For Contents 

 Font 

 Font Size 

 Indent 

 Space Before 

 Space After 

 Dividing Line (border) Above 

 Dividing Line (border) Below 

Undo/Redo 

NoteFiler now has both Undo and Redo and both are virtually unlimited. The undo feature will allow 

you to undo changes you make to Labels and Contents, deleted items, imported articles, merged articles, 

report configuration changes and more. 

Copy To and Move To 

You can use the Copy To or Move To commands to either copy or move an item with all of its children to 

a different location within the NoteFiler hierarchy. 

Find and Replace 

You can now find and replace text in your entire NoteFiler database or just the current article and its 

children. You can also confine the scope to a particular template or template field. 

Templates 

NoteFiler now includes templates that allow you to specify fields within the Contents field that will 

always exist. For example, you might have a ‘Recipe’ template that included these fields: Recipe Name, 

Description, Ingredients, Instructions, and Notes. You can define custom fonts, font sizes, and several 

paragraph attributes for each field so that they have a ‘finished’ look when you print them out. 

Define a Template for all Child Articles 

This feature makes the attachment of a Template automatic for all children of a particular NoteFiler 

article. For instance, if you create a Cabinet named Recipes and in each of the Drawers you create 

subcategories like Entrées, Desserts, Vegetables, etc., you can, for each of the subcategories, specify that 
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all Folders created under those Drawers will automatically have the Recipe template attached so that 

your recipes are always consistent. 

Date Created and Date Modified 

NoteFiler now keeps track of when you create or modify any article. 

Article Count 

You can now see how many articles are in each listbox. 

Both Automatic and Manual Backup 

NoteFiler can now be configured to backup whenever the program is closed and to also backup after a 

certain number of minutes have past while the NoteFiler database is open. 

If you backup manually, the backup will contain a timestamp so that you know when it was created. 

Hyperlinks 

NoteFiler now supports hyperlinks in the Contents field. Just click on the hyperlink to bring up your 

browser with the desired web page. 

More? 
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Chapter 

3 
How to Use Help 

There are a number of useful ways to get help while using NoteFiler. Knowing the available ways to 

access help will make using NoteFiler more enjoyable and will reduce time wasted trying to figure out 

how to accomplish filing tasks. 

Press F1 

The number one most important thing to remember is to press F1. NoteFiler has been designed to be 

context sensitive. If you are viewing a dialog in NoteFiler and you don’t understand some of the options, 

press F1. 

When you press F1, NoteFiler will display help on the dialog box you are currently viewing. Usually 

there is a graphic image of the dialog box in the help file along with the text that describes each option. 

In addition, there are frequently references to other parts of the help file that may provide additional 

information. 

Dialog Help Button 

At the top/right corner of most dialogs you will see a question mark. If you want help related to that 

dialog, just click that question mark and you will receive help that relates to that particular dialog. For 

both these dialogs and those that don’t have this question mark, you can usually get the same type of 

context sensitive help by pressing F1. 

 

 

Example of the question mark (circled in red) in a NoteFiler Dialog 

Search for Help On 

If the techniques listed above don’t provide satisfactory help, choose Help>Search for Help On. You will 

be presented with the index to the NoteFiler User’s Guide. The page numbers are linked to the pages 

within the User’s Guide so that all you need to do is click on the page number to go directly to the page 

containing the information you are interested in. 

Hover 

If you hold the mouse cursor over a toolbar icon for about a second, a popup hint will be displayed that 

provides a brief description of the icon’s function.  
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Chapter 

4 
Tutorial 

Tutorial Outline 

Below is the basic outline for creating a NoteFiler database and for adding information to that database. 

In the tutorial, you will create a recipe database using this outline. 

 Overview 

 Creating a NoteFiler Database 

 Adding a Recipe Cabinet 

 Adding categories for your Recipes 

 Adding a Recipe 

 Adding another Recipe 

 Printing a Report of your NoteFiler Database 

 Conclusion 

Overview 

The easiest way to describe NoteFiler is to give you an example of one type of information you might 

want to use it for. A good use for NoteFiler would be to keep track of your favorite recipes and our 

tutorial will use this as an way of introducing you to NoteFiler. Please note that this is just one of many 

things you might want to keep track of. You might also want keep track of your child’s sports events 

keeping notes of how he or she did and any special details about the event that you think are important. 

You might also want to keep track of your car’s maintenance. The possibilities are really limitless. 

The NoteFiler Hierarchy 

Before we get into our Recipes example, it is important that you understand the basic hierarchy of a 

NoteFiler database. NoteFiler contains Cabinets, Drawers, Folders and Items. The Cabinets are roughly 

the equivalent of a physical filing cabinet. The Drawers can be likened to the drawer in a physical filing 

cabinet and the Folders can be likened to the folders within each drawer of that filing cabinet. Finally, 

Items are what you would put in the folders of that filing cabinet.  

What is unique about NoteFiler as compared to a real filing cabinet is that you can put information in 

any of the four levels of hierarchy. In a conventional filing cabinet, the information is ultimately only 

available as items (pieces of paper) placed in a folder. In NoteFiler, you can also attach information to 

Cabinets, Drawers and Folders. 

The Basic NoteFiler article 

Everything you create in NoteFiler, regardless of the hierarchy level, is called an article. Every Cabinet, 

Drawer, Folder, or Item you create is an article. There is no difference between a Cabinet article or an 

Item article other than the hierarchy level. This makes NoteFiler much more useful than a physical 

filing cabinet. 
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Each NoteFiler article contains a Label and Contents. The label is simply a short description of the 

article which you might see as similar to the label you would put on a filing cabinet drawer or folder. The 

details about the article are placed in the Contents. As you’ll find out later, Contents can have templates 

attached to them and that makes them even more useful. However, for many, if not most, of your 

organizational needs, you’ll be able to get along without templates. Templates are discussed in Chapter 

18 Working with Templates. 

A Simple Example 

Let’s examine how you might keep track of your recipes using NoteFiler. To start, you could create a 

Cabinet might with the label ‘Recipes’ and the Contents might simply be the text: “This is a collection of 

my favorite recipes.” The drawers within the Recipes Cabinet might contain labels like Entrées, 

Desserts, Casseroles, etc. The Entrées Drawer might have the Contents: “These are main courses that 

my friends really enjoy.” The folders within the Entrees drawer might contain the labels: Shrimp 

Scampi, Pad Thai, Spaghetti Sauce Supreme, and so on. Each of those folders would contain instructions 

on how to make the entrée in the Contents. In this example, there probably would not be any ‘Items’ 

within the folders because all of the information needed is already contained at the folder level. 

Now that you know the basic structure of a NoteFiler database, let’s learn how to create a NoteFiler 

database and add items to it. 

Creating a NoteFiler Database 

To create a NoteFiler database, do the following: 

1. Choose File>New. (NoteFiler will display a file selection dialog.) 

2. Type “Tutorial” in the File name text box. 

3. Click Save. (NoteFiler will create a new database with the name "Tutorial.flr4" (the ‘.flr4’ 

filename extension is usually hidden in Windows File Explorer) and will open the new database 

ready for data entry.) 

Adding the Recipe Cabinet 

The starting point of every NoteFiler database is a Cabinet. A Cabinet represents the highest level item 

that you can add. After you’ve created a Cabinet, you can then add Drawers to it and once you’ve created 

a Drawer, you can add Folders to it and so on. 

To add a new Cabinet to your database, do the following: 

1. Click the New Cabinet button. (The Label Editor dialog will appear for you to specify a label for 

the cabinet.) 

2. For our example, enter “Recipes” as the label. 

3. Click OK 

Tip: When typing a label, don’t make it too long. Use the least amount of text necessary to adequately 

describe the Cabinet. For instance, use “Recipes” instead of “This is a collection of all my Recipes”. You 

can put as much detail as you wish in the Contents field later. 

Adding Categories for your Recipes 

Recipes are generally broken down into categories such as Entrées, Casseroles, and Desserts. For our 

tutorial, we’ll add two Folders – Entrées and Desserts. 
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Adding your first drawer 

Now that you’ve created your Recipes Cabinet, let’s add an Entrée category. Here’s how to do it: 

1. Make sure that your Recipes Cabinet is highlighted in blue. Click on it if it is not. 

2. Click the New Drawer button. (The Label Editor will appear.) 

3. Type ‘Entrée’s for the label’s name. 

4. Click OK. 

Adding another drawer 

After creating your first drawer, you can add additional ones by simply choosing Edit>New Folder or by 

pressing the keyboard shortcut Ctrl+E. Let’s do it: 

1. Press Ctrl+E. (The Label Editor will appear.) 

2. Type ‘Desserts’ for the label’s name. 

3. Click OK. 

Adding a Recipe 

Now that you’ve created a couple of categories for your recipes, let’s go ahead and add a recipe… 

Our first recipe will be a Chili recipe. The first thing we need to do is click on the Entrées category to 

select it. If you can’t see that category, click on the Recipe cabinet to reveal the two categories we just 

entered. 

Now that you’ve selected the Entrées category, click on the New Folder button and type ‘Chili’ for the 

label. Then click OK to accept your label. 

Now we’re going to type our recipe into the Contents Editor so click once in the Contents Editor to give it 

focus. Then type the text below: 

 

Please note that you can type bold text by pressing Ctrl+B before typing the text and then pressing 

Ctrl+B again to turn off the bold text. If you prefer you can bold the text after you’ve typed it by selecting 

the text and pressing Ctrl+B. You’re probably already familiar with this from using your favorite word 

processor. 

 

Ingredients 

 

1 lb. Ground beef 

½ cup diced onion 

8 oz can Heinz Tomato Sauce 

6 oz can Heinz Tomato Paste 

1 can Dark Kidney beans (drained) 

1 can Light Kidney beans (drained) 

¾ t. Cumin 

1 t. Chili powder 

¼ t. Pepper 

 

Instructions 

 

Cut the onion into small pieces and brown with the ground beef. Cook until onions are 

translucent. Add remaining ingredients and continue to heat while stirring until all ingredients 

are hot. 
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Adding another Recipe 

Our second recipe will be a recipe for Salmon Cakes. To enter it, click on the New Folder button and type 

‘Salmon Cakes’ for the label. Then click OK to accept your label. 

Now click once in the Contents Editor to give it focus and then type the text below: 

 

Ingredients 

 

7 oz can Salmon 

¼ cup Dry breadcrumbs or crackers 

¼ t. Salt 

Dash Pepper 

1 Egg 

1½ Tbl. Mayonnaise or salad dressing 

1½ Tbl. Butter or margarine 

 

Instructions 

 

Drain Salmon; discard bones and dark skin; fork into flakes. Mix salmon with crumbs, salt and 

pepper. Beat eggs slightly, add to mixture with mayonnaise. Shape into patties (3-4). Fry in 

melted fat until brown on both sides. (May add 2 stalks finely chopped celery to patties before 

frying.) 

 

You now know the basics for adding information in your NoteFiler database. There are lots of ways to 

manipulate your NoteFiler database so be sure to read Chapters 5 through 10 after you’ve finished the 

tutorial to learn how NoteFiler makes organizing your data easy. 
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Printing a Report of your NoteFiler Database 

One of NoteFiler’s best features is its ability to print a report of your information. The reports are highly 

configurable and can therefore be tailored to suit your needs. However, even though the reports can be 

customized, the default settings will be adequate for many if not all of your NoteFiler databases.  

To print a report, choose File>Print. The Report Wizard will appear to walk you through the two step 

process. 

 

Report Wizard: First Step 

The first step is to choose what will be printed. By default the entire NoteFiler database will be printed. 

For our tutorial, we’ll just print everything which is the default, so click the Next button. 

 

 

Report Wizard: Second Step 
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Now you can generate your report as a Rich Text File (RTF). Your generated report will be opened in the 

Word processor that you specify in the Open with drop-down list. Once the report is open in your word 

processor, you can do even more customizing of the report if NoteFiler’s the built in customizations 

aren’t sufficient for your needs. Click Finish to generate your report. This will generate the report and 

open it in your word processor. After you’ve examined it, please close your word processor and continue 

with the tutorial. 

Conclusion 

Well, that's all. You have finished the tutorial and you should now be able to use the basic features of 

NoteFiler to start entering and organizing your information. Please read the rest of the User’s Guide 

since there are still many useful things to learn that will make using NoteFiler more enjoyable and more 

efficient. 
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Chapter 

5 
NoteFiler Articles 

The remaining chapters of this User’s Guide are going to refer to NoteFiler ‘articles’. It is important for 

you to understand what a NoteFiler article is and that is what will be defined in this chapter. 

What is a NoteFiler Article? 

NoteFiler contains four listboxes that are labeled Cabinet, Drawer, Folder and Item. The list items in 

each of these listboxes are all NoteFiler articles. There is no difference between an article in the Cabinet 

list or an article in the Drawer list other than the list that it is in. 

Every time you use the New Cabinet, New Drawer, New Folder or New Item buttons to add something to 

that list, you are creating a new NoteFiler article. Each article you create has a Label and Contents. If 

you decide to use Templates, the article will also have template information attached. 

Whenever this User Guide refers to an article, it can be referring to any list item in any listbox. 

 

 
 

Example NoteFiler Program Window
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Chapter 

6 
Adding Cabinets, Drawers, Folders and Items 

Overview 

NoteFiler allows you to create databases that contain four levels of hierarchy. These four levels are 

called Cabinets, Drawers, Folders, and Items. These four levels that correspond nicely to a physical filing 

cabinet allow you to organize your information in an intelligent way and at the same time prevents you 

from creating so many levels that your information becomes difficult to find. 

This chapter deals with how you add articles to your NoteFiler database to create the hierarchy you 

desire. 

An important observation 

NoteFiler has a separate ‘New’ button for each listbox (Cabinet, Drawer, Folder, and Item). These 

buttons are enabled and disabled depending on whether or not the parent list has articles in it. For 

instance, If you have just created a brand new NoteFiler database, Only the New Cabinet and New 

Drawer buttons are enabled. The New Cabinet button is always enabled because it is the highest level. 

The New Drawer button is enabled because its parent list (the Cabinet list) does contain articles. Both 

the New Folder and New Item buttons are disabled because neither of their parent lists have any 

articles. When you create any new article, it becomes a child of the parent and therefore, it must have a 

parent to be attached to. 

Adding a New Cabinet 

The starting point of every NoteFiler database is a Cabinet. A Cabinet represents the highest level item 

that you can add. After you’ve created a Cabinet, you can then add Drawers to it and once you’ve created 

a Drawer, you can add Folders to it and so on. 

To add a new Cabinet to your database, do the following: 

1. Click the New Cabinet button OR if the Cabinet listbox has focus, choose Edit>New Cabinet. A 

dialog will appear for you to specify a label for the cabinet. 

2. Type a label that makes sense for the Cabinet you’re creating.  

3. Click OK. 

Tip: When typing a label, don’t make it too long. Use the least amount of text necessary to adequately 

describe the Cabinet. For instance, use “Recipes” instead of “This is a collection of all my Recipes”. You 

can put as much detail as you wish in the Contents field later. 

Adding a New Drawer 

To create a new Drawer: 

1. Click the New Drawer button OR if the Drawer listbox has focus, choose Edit>New Drawer. A 

dialog will appear for you to specify a label for the Drawer. 
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2. Type a label that makes sense for the Drawer you’re creating.  

3. Click OK 

Adding a New Folder 

To create a new Folder: 

1. Click the New Folder button OR if the Folder listbox has focus, choose Edit>New Folder. A dialog 

will appear for you to specify a label for the Folder. 

2. Type a label that makes sense for the Folder you’re creating.  

3. Click OK. 

Adding a New Item 

To create a new Item: 

1. Click the New Item button OR if the Item listbox has focus, choose Edit>New Item. A dialog will 

appear for you to specify a label for the Item. 

2. Type a label that makes sense for the Item you’re creating.  

3. Click OK. 

Tips for Creating New Articles Using the Keyboard 

If you like using a keyboard instead of a mouse, there are keyboard shortcuts that may help you more 

easily create articles at the desired level. The keyboard shortcuts are: 

Ctrl+1 – Give focus to Cabinet list 

Ctrl+2 – Give focus to Drawer list 

Ctrl+3 – Give focus to Folder list 

Ctrl+4 – Give focus to Item list 

After you’ve given focus to the desired list, you can press Ctrl+J to create a new article in that list. 

Notes 

 You cannot give focus to a list whose parent list does not have a selected article. In this case, 

pressing one of the shortcuts to give focus to that list will result in a beep. 

 If the list you want to add an article to is already the current list (has focus), there is no need to 

press one of the keyboard shortcuts listed above to give focus to the list. 

Using Drag and Drop to Create a New Article 

Many people will use NoteFiler as a way of keeping track of information they find in the news or online. 

In order to make it easy to add information from a web browser or other program into NoteFiler we’ve 

added a way to drag and drop information and create a new article at the same time. 

To create a new article using drag and drop do the following: 

1. Select the text to become the Contents of the new article in the other program 

2. Drag the text over the list that you want the new article created in.  OR  Drag the text over one 

of the ‘New’ buttons for a Cabinet, Drawer, Folder, or Item. 

3. Drop the text. NoteFiler will create a new article in the list you dropped it in with the label: “* 

New Article: MM/DD/YYYY” where MM/DD/YYYY is the current date. 
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4. If you wish to change the label, just double click on the newly created article to bring up the 

Label Editor. 

You will now have a new article that includes your copied text. 

Notes 

If the ‘New’ button for a list is grayed out, it means that you cannot create a new article in that list. 
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Chapter 

7 
Selecting Articles 

In order to effectively use NoteFiler, you must understand how to select articles and understand what 

the Current article is. This chapter provides information on both of those topics. 

The Current Article 

It is important to understand what article is the ‘current’ article while working with your NoteFiler 

database. When you are adding or editing anything in the Contents Editor, the text you’re adding or 

editing is attached to the currently selected article. 

Fortunately, it is easy to determine the current article. Each listbox that contains articles will have a 

highlighted list item. However, only one of them will be highlighted in blue. The rest will be highlighted 

in light gray. The one that is highlighted in blue is the current NoteFiler article. That is the article who’s 

Contents appears in the Contents Editor. 

Selecting an Article (making it the current article) 

Selecting an article makes it the Current article. Making it the current article allows you to edit its 

Contents. You can select an article with the mouse or with the keyboard. First we’ll describe how to 

select an article with the mouse. 

Selecting an article with the mouse 

To select an article with the mouse, just click on the desired article. If the desired article is not visible, 

you can scroll the articles in listbox using the scroll bar and then click the desired item. 

Selecting an article with the keyboard 

Selecting an article with the keyboard requires two steps: 

1. Give focus to the listbox that contains the article you want to select 

2. Highlight the desired article. 

Giving focus to the desired listbox with the keyboard 

Step one can be done in two ways, the first is to press Tab or Shift+Tab to give focus to the next or 

previous listbox. The listbox that has focus will have a double wide blue border. All other list boxes will 

have a light gray single width border. In addition, if the listbox with focus has any articles in it, the 

selected article in that list will be highlighted in blue. Another shortcut for selecting a listbox is to hold 

down the Control key on your keyboard and press one of the numbers 1 through 4. ‘1’ corresponds to the 

Cabinet list, ‘2’ to the Drawer list, and so on. 

Note: If you give focus to the Contents editor by pressing Tab and want to give focus back to one of the 

listboxes, you will have to press Ctrl+Tab instead of just Tab since tabs are legal characters in the 
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Contents of an article. Moving focus backwards from the Contents editor requires you to press 

Ctrl+Shift+Tab. 

Highlighting the desired article 

Once you’ve given focus to the desired list, you can select articles in the list by using the up and down 

arrow keys to move one article at a time or the Page Up and Page Down keys to go up or down in the list 

a full page of articles. The Home key takes you to the very first article in the list and the End key takes 

you to the last. Finally, you can press an alphabet letter to take you to the first article in the list that 

contains a label starting with that letter. If there is more than one label with that letter, you can press 

the letter repeatedly to cycle through all articles that contain a label starting with that letter. 
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Chapter 

8 
Working with Articles 

Overview 

This chapter details how to work with articles in your NoteFiler database. One of NoteFiler’s best 

strengths is it robust ability to manipulate those articles so getting to know what’s available to perform 

those manipulations is important to getting the most out of NoteFiler. 

Copying an Article 

One of the nicer features of NoteFiler is the fact that it lets you reorganize your information easily. In 

part, this is handled by the ability to copy, cut, paste and delete articles while including all of their 

children. The Copy command will copy an article and all of its children. 

Copying an Article with all of its children 

To copy an article and all of its children to the Windows clipboard, do the following: 

1. Select the article to be copied. 

2. Copy the article using one of the following methods: 

 Choose Edit>Copy. 

 Press Ctrl+C. 

 Click the  toolbar icon. 

 Right-click on the selected article and choose Copy from the popup menu. 

See also: Cutting an Article; Deleting an Article; Pasting an Article 

Copying an Article without Children 

Normally, when you copy an article, you’re going to want all of its children to be copied also. There may 

be times, however, when you simply want to copy the current article without the attached children. To 

do that, you use the Copy (w/o children) command. The keyboard shortcut simply adds the shift key, so 

that should not be hard to remember. 

Copying an Article without copying its children 

To copy an article without copying its children, do the following: 

1. Select the article to be copied. 

2. Copy the article using one of the following methods: 

 Choose Edit>Copy (w/o children). 

 Press Ctrl+Shift+C. 

See also: Cutting an Article; Deleting an Article; Pasting an Article 
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Creating a New Article 

Creating new articles is also discussed in Chapter 6 Adding Cabinets, Drawers, Folders and Items 

NOTE: The instructions below are for creating a new article in the Cabinet list. The instructions for 

creating a new article in the Drawers, Folders, or Items list is the same with the exception that you’ll 

click the appropriate button for the list that you wish to add the article to. 

To add a new article in the Cabinet list, do the following: 

1. Click the New Cabinet button OR if the Cabinet listbox has focus, choose Edit>New Cabinet. A 

dialog will appear for you to specify a label for the cabinet. 

2. Type a label that makes sense for the Cabinet you’re creating.  

3. Click OK. 

Tip: When typing a label, don’t make it too long. Use the least amount of text necessary to adequately 

describe the Cabinet. For instance, use “Recipes” instead of “This is a collection of all my Recipes”. You 

can put as much detail as you wish in the Contents field later. 

Cutting an Article 

The Cut command will copy an article and all of its children to the Windows clipboard and then will 

delete that article and all of its children from the database. 

Cutting an Article 

To cut an article and all of its children to the Windows clipboard, do the following: 

1. Select the article to be cut. 

2. Cut the article using one of the following methods: 

 Choose Edit>Cut. 

 Press Ctrl+X 

 Click the  toolbar icon. 

 Right-click on the article within one of the article lists and choose Cut from the popup menu. 

See also: Copying an Article; Deleting an Article; Pasting an Article 

Deleting an Article 

The Delete command will delete an article and all of its children. You can use Edit>Undo to recover the 

deleted article if you do this by mistake. 

Deleting an Article and all of its children 

To delete an article and all of its children, do the following: 

1. Select the article to be deleted. 

2. Cut the article using one of the following methods: 

 Press Del. 

 Choose Edit>Delete. 

 Click the  toolbar icon. 

 Right-click on the article to be deleted and choose Delete from the popup menu. 

See also: Copying an Article; Cutting an Article; Pasting an Article 
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Duplicating an Article 

The duplicate function makes a copy of the current article. You can choose to duplicate the article with 

or without including any children the article may have. 

Duplicating an article including all of its children 

To duplicate an article and include all of its children, do the following: 

1. Select the article to be duplicated. 

2. Choose Edit>Duplicate. 

Keyboard Shortcut: Ctrl+D 

See also: Copy To 

Note: The duplicated article’s Label will have “_Copy” appended as a suffix. 

Duplicating an article without including its children 

To duplicate an article without including its children, do the following: 

1. Select the article to be duplicated. 

2. Choose Edit>Duplicate (w/o children). 

Keyboard Shortcut: Ctrl+Shift+D 

Note: The duplicated article’s Label will have “_Copy” appended as a suffix. 

Moving (or Copying) an Article to another location  

Move To 

The Move To command allows you to move an article along with all of its children to another location in 

the current NoteFiler database. 

Example 

Assume you have the following Cabinets, Drawers: 
 Car 
  Check Belts 
  Oil Changes 
  Tire Rotation 

Truck 
  Check Belts 
  Oil Changes 
  Tire Rotation 

You decide that you want to create a new Cabinet named Maintenance and place both the Car and Truck 

folders within that new cabinet. After you create the Maintenance cabinet, you can use the Move To 

command to move the Car and Truck Cabinets to become Folders under the new Maintenance Cabinet. 

Once you’ve completed the move, you’ll have this structure: 

 

 Maintenance 
 Car 
  Check Belts 
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  Oil Changes 
  Tire Rotation 
 Truck 
  Check Belts 
  Oil Changes 
  Tire Rotation 

To Move an Article to another Location 

1. Select the article you want to move to another location. 

2. Choose Edit>Move To or Click the Move To toolbar icon. 

The Move To dialog will appear which contains a tree list of all the locations you can move 

the currently selected article to. An example is shown below: 

 

Example of the Choose Destination Dialog 

By default, only Cabinets are shown. If your desired location is a drawer, folder, or item, just 

click the plus sign in front of the Cabinet that contains it and the tree will be expanded to 

show its folders. Click the plus sign in front of the folders to reveal Items. 

3. Choose (click on) the desired ‘parent’ article. 

4. Click OK. 

Notes 

Please be sure to notice that the article you are moving will become a child of the article you select. If 

you want to move an article to become a Cabinet, choose “[Choose this to ‘Move To’ the Cabinet list.]”. 

Keyboard Shortcut: Ctrl+M 

See also: Copy To 

Repeating the last Move To 

There may be times when you want to move more than one article to the same destination. In order to 

make this process easier, after you’ve moved one article to the new location, you can use the Move To 

Again command to move additional articles with a single keystroke. 

To move the current article to the same location as the most recent Move To, do the following: 

1. Choose Edit>Move To Again (or press the keyboard shortcut Ctrl+G) 

Notes 

 You cannot use this command until you have used the Move To command at least once since the 

destination is determined by the Move To command. 
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 NoteFiler will not allow you to move an article that would result in one or more child articles 

being below the Item level in the NoteFiler Hierarchy. 

Keyboard Shortcut: Ctrl+G 

See also: Move To 

Copy To 

The Copy To command is virtually identical to the Move To command. The difference is that instead of 

moving the selected article to the new location, the selected article will copied to the new location. You 

will then have the same article in two places in your NoteFiler database. Please note that the Duplicate 

command is usually preferable to the Copy To command. 

To Copy an Article to another Location 

1. Select the article you want to move to another location. 

2. Choose Edit>Move To or Click the Move To toolbar icon. 

The Copy To dialog will appear which contains a tree list of all the locations you can move 

the currently selected article to. By default, only Cabinets are shown. If your desired location 

is a drawer, folder, or item, just click the plus sign in front of the Cabinet that contains it and 

the tree will be expanded to show its folders. Click the plus sign in front of the folders to 

reveal Items. 

3. Choose (click on) the desired ‘parent’ article. 

4. Click OK. 

Notes 

Please be sure to notice that the article you are copying will become a child of the article you select. If 

you want to copy an article to become a Cabinet, choose “[Choose this to ‘Copy To’ the Cabinet list.]”. 

Keyboard Shortcut: Ctrl+T 

See also: Move To 

Pasting an Article 

The Paste command will paste the articles in the Windows clipboard into the listbox that currently has 

focus. 

Pasting an Article 

To paste the articles in the Windows clipboard to the listbox that currently has focus, do the following: 

1. Select the listbox you wish to paste the clipboard contents to. 

2. Paste the clipboard contents using one of the following methods: 

 Press Ctrl+V. 

 Choose Edit>Paste. 

 Click the  toolbar icon. 

 Right-click anywhere in the listbox you wish to paste into and choose Paste from the popup 

menu. 

See also: Copying an Article; Cutting an Article; Deleting an Article 
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Renaming an Article 

Sometimes you will change your mind about how an article is labeled. Sometimes it is to simply get it to 

sort differently. Other times to make it more clear what it represents. Whatever the reason, it is a simple 

matter to rename your articles. 

To Rename an Article 

1. Select the article you wish to rename. 

2. Choose Edit>Rename or press F2. (The Label Editor will appear.) 

3. Edit the label using the Label Editor. 

4. Click OK. 

Keyboard Shortcut: F2 
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Chapter 

9 
Working with the Contents Editor 

Overview 

One of the most important aspects of NoteFiler is the ability to attach a description to any article in the 

database. The description can be as short or long as you desire and can contain the standard character 

formatting bold, italic, and underline. 

Adding Text to Contents 

When you create a new article in NoteFiler, its Contents is empty by default. To add Contents you can do 

the following: 

1. Type text directly into the Contents Editor. 

2. Copy text from another source such as a word processor and paste it into the Contents Editor. 

3. Drag text from another source and drop it into the Contents Editor. 

Notes 

 NoteFiler can only accept text from other programs that appear in the Windows clipboard or 

drag and drop buffer in the appropriate format. If you try dragging text to NoteFiler and it does 

not work, try copy and paste instead. Similarly, if you try pasting text and it does not work, try 

drag and drop instead. This is particularly a problem with web browsers. Different web browsers 

put different types of text in the clipboard and drag and drop buffer so trying a different web 

browser may also be beneficial. 

Editing Contents 

To edit contents that already exist, simply select the article that contains the desired contents and then 

edit the contents directly in the Contents Editor as you would in a word processor. 

Applying Character Style (Bold, Italic, Underline, Strikeout) 

NoteFiler supports four character styles: bold, italic, underline, and strikeout. Character styles can be 

applied with the keyboard or the mouse. The examples below assume you are applying a bold character 

style. To apply italic or some other character style, substitute the appropriate style. 

Applying a Character Style as You Type 

1. Press the keyboard shortcut for the format that you wish to apply. This turns on the character 

style. 

2. Type the text that you wish to format. 

3. Press the keyboard shortcut for the format that you are applying again. This turns off the 

character style. 
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Applying a Character Style to Selected Text 

To apply a character style to selected text, do the following: 

1. Select the text to apply the character style to. 

2. From the Format menu, choose the style you wish to apply or use one of the keyboard shortcuts 

shown below. 

Notes 

 You can also click one of the toolbar icons for bold, italic, or underline to apply a character style 

also. They are:     

 You cannot apply character styles to text in template fields that do not have the ‘Allow Styled 

Text’ property set to true. 

Keyboard Shortcuts 

Bold: Ctrl+B 

Italic: Ctrl+I 

Underline: Ctrl+U 

Strikeout: Ctrl+Shift+T 

Changing the Color of Text 

You may change the color of text in the Contents Editor in order to reflect importance or association with 

other text of the same color. To do this, do the following: 

1. Select the text that you wish to change the color of. 

2. Choose Format>Font Color or click the  toolbar button. The Color Selection Dialog will 

appear. 

3. Choose the desired color. 

4. Click OK 

Keyboard Shortcut: Ctrl+Shift+O 

Notes 

 You cannot change the color of text in template fields that do not have the ‘Allow Styled Text’ 

property set to true. 

Creating Superscript or Subscript Text 

NoteFiler allows you to enter superscripted or subscripted text for those rare occasions that they are 

needed. To change plain text to superscript or subscript, do the following: 

1. Select the text to be modified. 

2. Choose Superscript or Subscript from the Format menu or click the  or  toolbar buttons. 

Keyboard Shortcuts: Ctrl+Shift+U, Ctrl+Shift+B 

Notes 

You cannot create super or subscript text in template fields that do not have the ‘Allow Styled Text’ 

property set to true. 

Copying, Cutting, Pasting, and Deleting Text 
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Overview 

The customary clipboard commands take on two roles in NoteFiler. The first is the same one you’re used 

to in your word processor – working with text. The second is to allow you to work with NoteFiler articles 

and the children attached to them. An article plus its children is called a tree. This chapter discusses 

using the Windows clipboard for working with text. The next chapter describes using the clipboard to 

work with articles. 

Copy (text) 

You may copy the text from the Contents Editor to the Windows clipboard so that it may be pasted into 

the contents of a different article. You can also copy and paste text to and from other programs. 

Copying Text 

Select the text to be copied. 

Copy the text to the clipboard in one of the following ways: 

 Click the  toolbar icon. 

 Choose Edit>Copy. 

 Press Ctrl+C. 

 Right-click on the selected text and choose Copy from the popup menu. 

See also: Cut; Delete; Paste 

Cut (text) 

You may cut the text from the Contents Editor to the Windows clipboard so that it may be pasted into 

the contents of a different article. You can also cut and paste text to and from other programs. 

NOTE: The Cut command is identical to performing the Copy command followed directly by the Delete 

command. 

Cutting Text 

Select the text to be cut. 

Cut the text to the clipboard in one of the following ways: 

 Click the  toolbar icon. 

 Choose Edit>Cut. 

 Press Ctrl+X 

 Right-click on the selected text and choose Cut from the popup menu. 

See also: Copy; Delete; Paste 

Paste (text) 

You can paste text from the Windows clipboard into the Contents Editor. 

Pasting Text 

To paste text from the Windows clipboard into the Contents Editor, do the following: 

 Place the text cursor at the place you want the pasted text to appear or select some text that you 

want to be replaced by the pasted text. Then: 

 Click the  toolbar icon. 
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 Press Ctrl+V. 

 Choose Edit>Paste. 

 Right-click at the insertion point or on the selected text and choose Paste from the popup 

menu. 

See also: Copy; Cut; Delete 

Delete (text) 

You can delete text from the Contents Editor in several different ways. The various ways are discussed 

below. 

Deleting One Character at a Time 

To delete one character at a time from the Contents Editor, do one of the following:: 

 Press Backspace to delete the character to the left of the text cursor. 

 Press Delete to delete the character to the right of the text cursor. 

Deleting Several Characters at a Time 

First, select the text to delete and then do one of the following:  

 Click the  toolbar icon. 

 Choose Edit>Delete. 

 Press Delete. 

 Right-click on the selected text and choose Delete from the popup menu. 

Deleting a Word at a Time 

To delete a word at a time, do either of the following: 

 Press Ctrl+Backspace to delete one word backward. 

 Press Ctrl+Delete to delete one word forward. 

See also: Copy; Cut; Paste 

Making a Bulleted List 

Most NoteFiler users will find that they want to create a bulleted list of items from time to time. This is 

as easy as a single mouse click. To create a bulleted list, do this: 

1. Select the lines of text that you wish to create a bulleted list of. 

2. Choose Format>Bullets or click the  toolbar icon 

Notes 

 When NoteFiler creates a bulleted list, the list will be indented by .25 inches and have a hanging 

indent of .25 inches regardless of what the indent or hanging indent was prior to creating the 

bulleted list. 

 When you toggle a bulleted list off, the indent and hanging indent will be set to 0 no matter what 

they are prior to removing the bullets 

 In order for a paragraph to have the bullet attribute, there must be a paragraph break following 

the list item. If you don’t have the following paragraph break, the last paragraph in the bullet 

list will not have the bullet after the contents is saved and reloaded and will appear as a normal 

paragraph. 
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Keyboard Shortcut: Ctrl+Shift+L 

Notes 

You cannot create bullet lists in template fields that do not have the ‘Allow Styled Text’ property set to 

true. 

Setting Font and Font Size 

NoteFiler allows you to set both the font and font size for any text in the Contents Editor. There are two 

ways to do this. The first and most efficient is to simply use the toolbar controls. Those controls are 

shown below. 

 

Toolbar Controls for setting Font and Font Size 

In either of these controls, you can either choose the desired font or size by clicking the down arrow to 

display a list of choices or you can type your desired setting in the text area of the control. Please note 

that you must select the text to be changed before making your desired settings. 

The second way to do this is to use the Font Properties dialog which can be displayed by choosing 

Format>Font. The Font Properties dialog is shown below. 

 

 

The Font Properties Dialog 

The font controls in this dialog work the same way as in the toolbar controls described above. 

Notes 

 NoteFiler allows a maximum font size of 36 points and a minimum size of 6 points. 

 NoteFiler does not support right to left text and therefore does not support fonts intended to 

display text from right to left. 

 You can quickly adjust the font size up or down one point by using the Decrease/Increase Font 

Size buttons  and . The keyboard shortcuts for these buttons are Ctrl+[ and Ctrl+] 

respectively. 

 You cannot change the font properties of text in template fields that do not have the ‘Allow 

Styled Text’ property set to true. 

Keyboard Shortcut: Ctrl+Shift+F 

Setting Paragraph Justification 
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Your reports may require centered or right justified text for certain types of material. This is easy to 

accomplish in NoteFiler. To set the justification of one or more paragraphs in the Contents Editor, do the 

following: 

1. Select the text that you wish to justify 

2. Choose Format and then the appropriate justification (Left, Center, or Right) 

Notes 

 You cannot set the paragraph justification of text in template fields that do not have the ‘Allow 

Styled Text’ property set to true. 

 You can also click one of the toolbar icons for justify your text. The icons for Left, Center, and 

Right justification are:     

Keyboard Shortcuts: Ctrl+L, Ctrl+E, Ctrl+R 

Setting a Paragraph’s Properties (setting indents) 

NoteFiler allows you to set a paragraph’s indention and its justification (sometimes called alignment). A 

screen shot of the Paragraph Properties dialog is shown below. The available properties are: 

Indents 

From left margin – the distance from the left margin to the left edge of the paragraph. 

From right margin – the distance from the right margin to the right edge of the paragraph. 

Hanging – the additional distance to indent the second and all remaining lines of a paragraph 

in addition to the first line’s indent. 

Justification 

Left – The paragraph’s left edge will align with the left margin (plus any indent) 

Center – The paragraph will be centered between the left and right margins 

Right – The paragraph’s right edge will align with the right margin (plus any indent) 
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Paragraph Properties Dialog 

To adjust paragraph properties, you may use the Paragraph Properties dialog which can be displayed by 

choosing Format>Paragraph Properties or by clicking the  toolbar icon. 

Once you’ve displayed the Paragraph Properties dialog, just set the desired indent distances can click 

OK. All measurements are in inches. 

Notes 

 If you select multiple paragraphs with different indents and alignments, the initial state of this 

dialog will, obviously, be incorrect for some of those paragraphs since it can only show one value. 

NoteFiler will only modify the settings that you actually change in this dialog. So, if you have 

selected two paragraphs and the first has an indent of .25 and hanging indent of .5 and the 

second has an indent of .5 and a hanging indent of .25, if you change the indent to .5, and both 

paragraphs will then have an indent of .5, but the hanging indents will remain .5 and .25 

respectively unless you actually modify that value in this dialog. 

 A paragraph’s justification can also be adjusted by using the toolbar buttons:     

 You cannot change the paragraph properties of text in template fields that do not have the ‘Allow 

Styled Text’ property set to true. 

Keyboard Shortcut: Ctrl+Shift+P 

Tables within Contents 

Although it is possible to insert tables into the Contents Editor by copying them and pasting them from 

another source, NoteFiler does not provide support for these tables and they will cause problems with 

generated reports. 

If you don’t plan on generating a report with the article that contains the table and if you don’t mind 

that you can’t manipulate the tables, other than the text within them, there is no reason not to keep 

them in your Contents. However, if you are going to be generating reports you will want to convert those 

tables to plain text and try to arrange them using tabs instead. 
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To remove tables from the Contents Editor, select all the text that is within the table and then choose 

Format>Selection To Plain Text. This will remove the table, but leave the text. It also removes any 

formatting that may have been applied to the text so you may have to reformat the text. 

Tabs 

It is important that you understand how to use tabs in the Contents Editor because tabs serve two roles 

in NoteFiler. The first and primary role is the same role tabs play in almost all Windows programs, 

pressing tab moves the program’s ‘focus’ to the next control that can have focus. In NoteFiler, the four 

listboxes (Cabinet, Drawer, Folder, and Item) can have focus and the Contents Editor can have focus. If 

you press tab when a listbox has focus, focus is moved to the next listbox or, if the current listbox is the 

Items listbox, to the Contents Editor. Once the Contents Editor has focus, pressing tab inserts a tab into 

the text you are typing. This is usually what you want to happen. However, if you want to move focus to 

the next control from the Contents Editor, hold down the Ctrl key while pressing tab. If you want to 

move focus to the previous control rather than the next control, press Ctrl+Shift+Tab. 

Converting Formatted Text to Plain Text 

There will likely be times when you copy text that is highly formatted and you don’t really want the 

formatting to be retained. The Selection to plain text command will remove all formatting from the text 

that is currently selected. You can leave the text unformatted or apply your own formatting after you’ve 

done this. This command is useful for removing tables from pasted text since tables can cause problems 

the NoteFiler’s reports. 

To remove all formatting from selected text, do the following: 

1. Select the text that you wish to remove the formatting from. 

2. Choose Format>Selection to Plain Text 
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Inserting a Link (Referencing Another Article from the Current Article) 

There may be times when you would like to refer to another article within your database from the 

current article. An example would if you had a database of song and the database included a separate 

list of singing groups (and/or artists/composers) with details about those groups and in the article for an 

album or CD, you want to refer to that group so you can quickly read about that group’s history. You can 

also think of it as a way to insert a reference to related articles. 

What is a link? 

A link in NoteFiler is just like a hyperlink in your web browser. When you click on it, you are taken the 

web page (in the case of NoteFiler, the article) that the link refers to. An article link in NoteFiler looks 

like this: 

[Text describing the linked article] www.filerlink.208 

In the example above, the text between the square brackets is text that will appear in reports that you 

generate. The number ‘208’ is the ID of the article being referenced and is an internal number that you 

don’t need to worry about. 

Another example: 

[Mark Twain] www.filerlink.30 

In the above example, we’re referring to an article about the author ‘Mark Twain’ and the ID of the 

article containing that information is ‘30’. 

How do I insert a link? 

To insert a link, do the following: 

1. Place the insertion point where you want the link to appear. 

2. Choose Insert>Link. The Insert Link dialog will appear as shown below. 

3. Type a few letters of the article’s label that you wish to reference. The listbox below your typing 

will fill with potential candidates.  

4. Once your desired article appears in the list, select the article. This will fill in the link text. 

5. If desired, edit the link text. 

6. Click Insert to insert the link. 

 

http://www.filerlink.208/
http://www.filerlink.30/
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Insert Link Dialog 

Notes 

You need to be aware that links can be broken in the following ways: 

 Deleting the referenced article 

 Creating a copy (duplicating) the referenced article and then deleting the original. Note that 
moving a referenced article will not break the link. 

 Restoring a database from a Backup. This is true because article ID change during the process of 

recreating the database. 

Embedding a Document into Contents 

An embedded document is a full copy of a document – not a link to the document – that is stored in 

NoteFiler’s contents or a template field if you have an attached template. Once embedded, you can delete 

the original file from your computer and still have access to it from within NoteFiler. 

As an example of a use for embedding a document, you might want to embed an excel spreadsheet of 

your blood pressure readings if you are keeping track of health related items with NoteFiler. You can 

open the spreadsheet by double clicking it within NoteFiler, add a new blood pressure reading, and, 

when you save it, the changes are saved right back in NoteFiler. 

To embed a document, please do this: 

1. Open a Windows Explorer window (call File Explorer in Windows 8). 

2. Navigate in Windows Explorer to the file you want to embed. 

3. Drag the file from Windows Explorer to the contents of NoteFiler you want it to be embedded in 

and drop it there. Note: If Windows Explorer is covering NoteFiler so that you can’t see the 

contents, first drag the file over the NoteFiler icon in the Windows taskbar, which will make 

NoteFiler come to the front of all other programs, and then drag it to the contents area and drop 

it there. 

Working with Contents in a Larger Editor (the Big Editor) 
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When working with contents – especially when working with contents in a field of a template – you may 

find that you wish you could make the Contents Editor larger. Fortunately there is an easy way to do 

this. If you ever want to work with contents in a larger editor just make sure the contents has focus and 

press Shift+F2. A large contents editor that can be resized to be even larger will appear as shown below. 

When you’re done editing, just click OK (or press Alt+O) and the large editor will close and your edits 

will be displayed in the normal Contents Editor. 

 

 

Big Editor 
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Chapter 

10 
Working with Pictures 

Overview 

Most NoteFiler users will want to add pictures to their contents at some point. Fortunately it is easy to 

add pictures to your contents. However, pictures can consume a tremendous amount of space in your 

NoteFiler database and can cause your database to become slow to respond if you don’t use some 

diligence to ensure that you’re photos are properly sized. This chapter describes how to add, remove and 

resize your pictures within NoteFiler without affecting the original picture’s size and also how to change 

the size of your pictures using Microsoft Paint to ensure that you don’t waste a lot of database space 

unnecessarily. 

Inserting a Picture 

There are three ways to insert a picture into the Contents Editor: using Copy/Paste, Drag and Drop, or 

using the Insert menu. 

Inserting with Copy and Paste 

To insert a picture using copy and paste, do this: 

1. Select the picture in the source document and copy it to the Windows clipboard. 

2. Put the insertion point at the place where you want the picture in your contents. 

3. Choose Edit>Paste or press Ctrl+V 

Notes 

In order to be successful, the source program must place the appropriate format in the Windows 

clipboard. If you find that you can’t paste the picture, you may find that pasting into your word processor 

first and then copying and pasting into NoteFiler will succeed. You may also find that pasting into a 

photo editor such as Photoshop or Paint will allow you get the photo into NoteFiler. 

Inserting a Picture with Drag and Drop 

To insert a picture using drag and drop, do this: 

1. Select the picture in the source document. 

2. Click on the picture in the source document and continue to hold down the left mouse button as 

you drag the picture to NoteFiler. 

3. Drag the picture to the place in your contents you wish it to appear and release the left mouse 

button. 
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Notes 

In order to be successful, the source program must place the appropriate format in the drag buffer. If you 

find that you can’t drag and drop the picture, you may find that dragging into your word processor first 

and then dragging into NoteFiler will succeed. You may also find that dragging into a photo editor such 

as Photoshop or Paint will allow you get the photo into NoteFiler. 

Inserting a Picture from a File on your Computer 

If you have a picture in a file on your computer – for instance a photo taken with your digital camera – 

you can insert that picture into your NoteFiler contents as follows: 

1. Put the insertion point at the place within your contents where you wish the picture to be placed. 

2. Choose Insert>Picture. A Files dialog will appear. 

3. Using the Files dialog, navigate to the folder containing the desired picture. 

4. Select the picture you wish to insert. 

5. Click Open. 

Notes 

NoteFiler supports the following file formats: JPG (Joint Photographic Experts Group), BMP (Bitmap), 

GIF (Graphics Interchange Format), PNG (Portable Network Graphics), TIF (Tagged Image File 

Format) 

Deleting a Picture 

To delete a picture that is in your contents, do the following: 

1. Click on the picture to select it. You’ll see small square boxes at the corners of the picture when 

you’ve successfully done this. 

2. Choose Edit>Delete or press the Delete key on your keyboard. 

Resizing Pictures 

New in NoteFiler 4.0 is the ability to put pictures into the Contents Editor. You will likely find that some 

of the pictures that you paste into the Contents Editor are too large (possibly way too large) and you will 

want to make them smaller. There are two ways to do this, but we strongly recommend that you use the 

second method because it will significantly reduce the space the picture consumes in your NoteFiler 

database.  

To Resize a Picture directly within NoteFiler 

If you click on the picture, a border will appear that includes sizing anchors. To resize the picture, just 

grab one of those sizing anchors with the mouse and drag in the direction desired direction to either 

shrink or enlarge the picture. 

To Resize a Picture using Windows Paint 

This is the preferred method of resizing a picture since it will also reduce the amount of space the picture 

consumes in your NoteFiler database. Pictures can consume a tremendous amount of space in the 

database and if you don’t exercise some care in making sure you don’t paste overly large pictures into 

NoteFiler, you will find that your database loads slowly and responds slowly, so please give serious 

consideration to using this method. It takes slightly longer, but is worth the effort. 
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To resize a picture using Windows Paint, do the following (assumes you are using Windows 8): 

1. Click on the picture to select it. You’ll see small square boxes at the corners of the picture when 

you’ve successfully done this. 

2. Click the Copy icon in the NoteFiler toolbar. 

3. Open the Windows Paint program. 

4. Paste the picture into Windows Paint by pressing Ctrl+V on your keyboard. 

5. Use Paint’s Resize feature to reduce the size of the picture. We recommend that you resize to a 

maximum height of 200 pixels. This is, of course, up to you and dependent on your desired use of 

the picture. 

6. Press Ctrl+C on your keyboard immediately after resizing the picture and before doing anything 

else. 

7. Select the picture in NoteFiler again and click the Delete icon in the NoteFiler toolbar. 

8. Click the Paste button in NoteFiler’s toolbar. 

That’s it. You’re now done. 

Notes 

 We are planning to create a video for our website to demonstrate this process. You will have to 

visit our website to determine if the video is available. 

 Pictures can consume a tremendous amount of space in your NoteFiler database. They can also 

create significant pauses in program operation while these large amounts of data are stored and 

retrieved from the database. Consequently, we recommend that you resize large pictures using 

Windows Paint to ensure smooth response of your program and to keep your NoteFiler database 

size reasonable. 
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Chapter 

11 
Generating a Report 

Overview 

Many NoteFiler users will want to print out hard copies of the information that they have accumulated 

while using the program. This could be a report of your home inventory, your favorite recipes, or your 

genealogy research. NoteFiler has built-in options that allow you to customize your reports. The 

customizations are rather extensive, but if you can’t get the exact report style you’re hoping for, you can 

generate your report as an RTF file and then modify it in your favorite word processor to tweak the 

report style for your own personal needs. 

Notes 

Please note that NoteFiler does not directly print a report, it sends the report in RTF format to your 

word processor and you can then use your word processor to print the report. NoteFiler has been 

designed to work best with Microsoft Word, but you can also use OpenOffice Writer which is a free 

program. OpenOffice Writer, however, does not support the Space Before and Space After attributes for 

Contents and Templates. This is a minor limitation, but worthy of note. 

The Report Wizard 

The Report Wizard is what you will use to print a report or to generate an RTF file. There are two basic 

steps for creating a report. The first is to choose what part of your NoteFiler database you want to 

include in the report and the second is to choose how to generate it – either directly printing it or 

generating an RTF file. 

Starting the Report Wizard 

To start the Report Wizard, do one the following: 

 Choose File>Print. 

 Click the  toolbar icon. 

 Choose Report>Generate Report. 

This will invoke the Report Wizard as shown below. 
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Report Wizard – Step 1 

 

Step 1: Choosing what is included in a Report 

Specifying the Scope of the Report 

One of Filers most important features is its ability to let you create a hierarchy. You may find that you 

want to print only one tree of that hierarchy. The report wizard will allow you to do just that. The part of 

the hierarchy that you choose to print is called the scope. Your choices are: 

All – Generates a report for everything in the NoteFiler database. 

Current Selection (with children) – Generates a report for the currently selected article and all 

of its children. 

Current Selection – Generates a report for the currently selected article. It does not include the 

children of that article. 

Including or Excluding Contents 

Although probably something that won’t be used often, you can choose to include or exclude the Contents 

field of each NoteFiler article when generating your report. One example of how this might actually be 

handy is if you have a real, physical filing cabinet (or something similar) that you’ve cataloged using 

NoteFiler and you want to label the drawers and folders of that cabinet. You can generate a report 

without the Contents and then cut the labels out after printing them. You could even print them on 

paper that has a sticky backing so that you can just peel off the back and place them on the drawer or 

folder. 

By default, all Contents will be included in a report. To exclude Contents, just uncheck the Include 

Contents checkbox. 

Specifying a Title for your Report 

The default title for your report is “NoteFiler Report”. If you would like a different title to appear in the 

report’s header, just clear the existing title and enter your preferred title. 
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Step 2: Generating or Printing your Report 

Once you’ve chosen the scope of your report, click the Next button to take you to step 2 of the wizard. A 

screenshot is shown below. 

 

 

Report Wizard - Step 2 

The second page of the wizard will allow you to choose the word processor that you wish to use for 

editing or printing your report. By default, Microsoft Word will be chosen if it is installed on your 

computer. If you have not installed any word processors on your computer, WordPad will be selected. If 

you have more than one word processor installed and you wish to use one other than the currently 

selected word processor, just choose the desired word processor from the list. Your choice will be 

remembered the next time you generate a report. 

After you have chosen your word processor, click Finish to generate your report. After the report has 

been generated, NoteFiler will open the report in your preferred word processor so that you can edit or 

print it. 

Adding a Table of Contents to your Report 

Reports you generate with NoteFiler contain outline level information for the article labels in the report. 

This means that if you want a table of contents for your report, all you have to do is insert a Table of 

Contents using Microsoft Word. Please refer to your word processor’s help system or User’s Guide for 

information on inserting a Table of Contents to learn how to do this. 

If you don’t see all levels of your NoteFiler hierarchy, it is not because the information is not included in 

your report it only means that you need to configure the table of contents. Please refer to your word 

processor’s help system or User’s Guide for information on editing a Table of Contents if you need to do 

this. 

Notes 

 If you receive an error message when trying to generate an RTF file, it is most likely because you 

have generated the same report previously and left it open in your word processor. If that is the 

case, you need to close your word processor and try again. 
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 The Report Wizard will close automatically after generating your report. If you decide not to 

generate a report, click Close to cancel the report and return to using NoteFiler. 

 Some of the report options available in the Report Options dialog are not supported by WordPad. 

Specifically, lines above or below contents are not supported and headers and footers are not 

supported which means you will not see a report title or page numbers or the date of the report. 

If you do not have MS Word, you should consider downloading and installing OpenOffice Writer 

which is a free word processor that does support all of the features of NoteFiler. 

 NoteFiler generates your report in a file that has the same name as your NoteFiler database but 

with a .RTF filename extension. If this file already exists, you’ll be asked if you wish to overwrite 

the existing file. If you chose yes, all changes you may have made to that existing report will be 

lost. 

Tips 

 If you use Templates with your NoteFiler data, you can customize your reports in significant 

ways to make them more useful and more aesthetically pleasing. 

 If you use Templates with your NoteFiler data and you have Contents that you’ve used tabs in to 

align text into columns, be sure to use the Preferences option “Use Report Options Font and Font 

Size for Contents” and also make sure that the total amount of text indention for the text fields 

that have tabs is aligned on a .5 inch boundary. If you don’t do both of these things, the tabs will 

not align the same way in the report as they do on-screen. 
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Chapter 

12 
Report Options 

Overview 

One of NoteFiler’s best features is its reports. NoteFiler offers a significant number of ways to customize 

your reports so that they are nicely formatted and easy to read. The Report Options dialog allows you to 

configure your report options. 

 

 

Report Options Dialog  
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Page Layout Options 

Before considering how your data will be represented in the report, you should define the margins of 

your report pages, the font used for headers and if the pages will be numbered and so on. 

 

 

Page Layout Options 

Page Size 

Width – Specifies the width of the paper in inches (assumes portrait orientation) 

Height – Specifies the height of the paper in inches (assumes portrait orientation) 

Landscape – If checked, the report will be generated in landscape orientation. 

Page Margins 

Top – The size of the top margin in inches. 

Bottom – The size of the bottom margin in inches. 

Left – The size of the left margin in inches. 

Right – The size of the right margin in inches. 

Page Header 

Font – Specifies the font that will be used in the header of your report. 

Font Size – Specifies the font size that will be used in the header of your report. 

Number Pages – If checked, your report header will include page numbers. 

Date Pages – If checked, your report header will include the current date the report was generated. 

Notes 

If you do not have Microsoft Word, NoteFiler will use WordPad to display your reports. Some of the 

report options available in this dialog are not supported by WordPad. Specifically, lines above or below 

contents are not supported and headers and footers are not supported which means you will not see a 

report title or page numbers or the date of the report. Because of this, if you do not have MS Word, you 

should consider either purchasing Microsoft Word or downloading and installing OpenOffice Writer 

which is a free word processor that does support all of the report options of NoteFiler. 
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Report Options for Cabinets, Drawers, Folders and Items 

You may configure the appearance of the labels for Cabinets, Drawers, Folders and Items individually. 

There is a tab in the Report Options dialog for each of these labels and each contains the same options. 

 

 

Report Options for Cabinets, Drawers, Folders and Items 

Options 

Font – Specifies the font that will be used in the header of your report. 

Font Size – Specifies the font size that will be used in the header of your report. 

Space Before – Specifies how much blank space will appear before the label in inches. 

Space After – Specifies how much blank space will appear after the label in inches. 

Indent – Specifies how far to indent the label from the left margin in inches. 

Bold – If checked, the label will appear in bold character style. 

Italic – If checked, the label will appear in italic character style. 

Underline – If checked, the label will appear in underline character style. 

Page Break – Depending on your selection, a page break will or will not be added before printing the 

article. Your options are: 

Never – A page break will never be added. 

Always – A page break will always be added. 

If prior article has contents – A page break will added only if the article that comes immediately 

before this article had some contents to print. If the contents were empty, no page break will be 

added. 
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Report Options for Contents (and Templates) 

NoteFiler allows you to customize how the contents of each article will appear in your reports. These 

options also apply to articles that have a template attached. 

 

 

Report Options for Contents 

Options 

Font – Specifies the font that will be used in the contents of each article in your report. (See notes below) 

Font Size – Specifies the font size that will be used in the contents of each article in your report. (See 

notes below) 

Indent – Specifies how far to indent the contents from the left margin in inches. 

Enforce Font Options – Specifies if the default font and/or font size should be enforced when 

generating a report. Your options are: 

Don’t enforce in reports – Your reports will reflect exactly the font and font sizes that 

currently exist in the contents of your articles. They will not be changed. 

Enforce font size only – When generating a report, NoteFiler will force the font size of all 

contents, including contents within templates, to be what is specified in Report Options. 

Note: This option can significantly slow down the generation of a report. 

Enforce font size and name – When generating a report, NoteFiler will force the font size and 

font name of all contents, including contents within templates, to be what is specified in 

Report Options. Note: This option can significantly slow down the generation of a report. 

Blank space above body text – Specifies how much blank space will appear before the contents of 

each article in your report in inches. If you check the “Draw border above” checkbox and leave the Blank 

space above at zero, a small amount of blank space will be added regardless in order to assure a good 

looking report. 

Blank space below body text – Specifies how much blank space will appear after the contents of each 

article in your report in inches. If you check the “Draw border below” checkbox and leave the Blank 

space below at zero, a small amount of blank space will be added regardless in order to assure a good 

looking report. 

Draw border above – If checked, a thin line will appear above the contents text. 

Draw border below – If checked, a thin line will appear below the contents text 
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Notes 

When you create a new article, the default font and font size for contents will either be the font and font 

size defined here or the font and font size defined in Preferences depending on whether or not you check 

the “Use Report Options Font and Font Size for Contents” check box in the Preferences dialog. 

However, the basic contents of a NoteFiler article can contain almost any font or font size and can have 

any mixture of font and font size. The font size you specify in report options for Contents is ignored 

unless you choose either to enforce the font name or both the font name and font size. In addition, if you 

use templates (discussed later in this User’s Guide) to enhance the contents of your articles and you 

define fields that do not have the ‘Allow Styled Text’ option enabled, those fields will always appear in 

either the font and font size specified here or in the font and font size specified in Preferences depending 

on whether or not you check the “Use Report Options Font and Font Size for Contents” check box in the 

Preferences dialog. 
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Chapter 

13 
Finding Information (Find All) 

Overview 

The Find All function is designed to assist in the quick location of specific text in one or more articles in 

your database. The Find All function will find all occurrences of the text in all articles and will display a 

list of all articles that contain the text. In addition, by clicking on a particular article’s Label, you can see 

the contents of that article and if it contains your search text, it will be highlighted in red. 

 

 

The Find All Dialog 
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Finding Text Anywhere in Your Database 

To find text anywhere in your database, do the following: 

1. Choose Search>Find All. 

2. Type the text you wish to find in the Find What textbox. 

3. Click Find All 

If the text is found anywhere in your database, a list of all articles containing the text either in the 

article’s Label or Contents will be displayed. If you click on one of the articles in the list, the Contents at 

the bottom of the dialog will display that article’s contents with the found text highlighted in red. 

Options 

Go To – If you click this button, NoteFiler will show the article that is currently highlighted in the Find 

All dialog in the main program screen. The Find All dialog remains open, but you can work with the 

main program screen if desired. Note: If you double click on a row in the list of matches that are shown, 

it is the same as clicking on the Go To button. 

Notes 

The Find All dialog can be resized to make it bigger. This can be useful if you have articles that contain a 

significant amount of text in their Contents. 

Example 

Below is a sample screenshot of a search for the word eggs in a recipe database. As you can see, the word 

eggs is highlighted in red in the contents to let you see the context in which the word exists. 

 

 

Sample Screenshot of a search for ‘eggs’
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Chapter 

14 
Using Find and Replace 

Overview 

Replacing existing text with something different is a common task for any database. This may range 

from a simple change of one word or phrase to another, but may also require advanced techniques for 

matching text in a specific template or template field. You can accomplish this and much more using the 

Replace dialog. 

Find and Replace Options 

When you are finding text, there are several options that are available to help you narrow in on the 

desired text. You must set your options appropriately before you start searching for your desired text. 

The Find and Replace dialog is shown below for reference. 

 

Find and Replace dialog 
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The options available when finding text are: 

Find Options 

Options 

Match Case – If checked, NoteFiler will not return a match unless the case of the text that was found 

matches the text you typed exactly. 

Whole word – If checked, NoteFiler will not return a match unless the text that was found is a word by 

itself – not part of another, larger, word. 

Where 

Labels and Contents – Both Labels and contents will be searched. 

Labels – Only Labels will be searched. 

Contents – Only Contents will be searched (this includes templates). 

Scope 

Selected Only – The currently selected article will be searched (children will not be included). 

Selected with Children – The currently selected article and all of its children will be searched. 

All – All articles (the entire database) will be searched. 

Confine Scope to Template 

Template – Only articles with the specified template attached will be searched. All fields in the 

specified template will be searched. No other templates will be searched and plain Contents will not 

be searched. 

Field – Further confines the above Template scope to only include the specified field within the specified 

template. 

Replace Options 

Maintain Case – If checked AND if you type your search text in all lower case, NoteFiler will retain the 

case of the found text when performing a replacement. This is how it works: If the found text is all 

lower case, the replacement text will be all lower case. If the found text has leading capital letter and 

all other letters are lower case, the replacement text will also have a leading capital letter with the 

remaining letters in lower case. If the more than one letter in the found text is upper case, the 

replacement text will be in ALL upper case. 

If any letters of the Replace text are in upper case this option is ignored and the replacement text will 

match what you typed exactly. 

Finding Text 

To find text in your database, do the following: 

1. Choose Search>Find and Replace 

2. Type the text that you wish to find in the Find textbox. 

3. Set the find options as desired. (see Find and Replace Options above) 

4. Click Find Next. 
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If the text was found, it will be shown in either the ‘Label’ textbox or ‘Contents’ textbox and will be 

highlighted as red text. In addition, NoteFiler will go to the appropriate article in the database and your 

Cabinet, Drawer, Folder and Item listboxes will be updated to show the article where the text was found. 

If you wish to find another occurrence of the text, click Find Next again. 

If your search phrase was not found or if no additional occurrences of it can be found, a message will be 

displayed to let you know. 

Keyboard Shortcut: Ctrl+H 

Replacing Text 

Replacing text is exactly like finding text with the following two exceptions: 

1. You will be specifying text that you want to replace the found text with. 

2. There is one additional option to consider prior to starting your search. 

The basic outline for replacing text is: 

 Bring up the Find and Replace dialog. 

 Specify the text you want to be replaced (the Find Text) 

 Specify the text to be used in place of the found text (the Replace Text) 

 Find the first occurrence of the Find Text 

 Replace each occurrence of the Find Text with the Replace Text case-by-case using Replace or… 

 Replace each occurrence of the Find Text with the Replace Text globally all at once using Replace 

All. 

To replace text, do the following: 

1. Choose Search>Find and Replace. 

2. Type the text you wish to find in the Find textbox. 

3. Press tab to move focus to the Replace textbox. 

4. Type the text you wish to replace the find text with. 

5. Set the options you wish to use for finding and replacing the text. (see Find and Replace Options 

above) 

6. Click Find Next to find the first occurrence of the Find text if it exists. 

If the text is found, NoteFiler will display the found text in either the Label or Contents textbox as 

appropriate highlighted in red so that you can easily see it. You may now choose to replace just this one 

occurrence of the found text by clicking Replace or you can replace all occurrences found in the currently 

defined scope by clicking Replace All. 

Notes 

Use Replace All carefully and keep in mind that you can use Undo to undo a global replacement. 
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Chapter 

15 
Undo and Redo 

Undo/Redo 

NoteFiler includes a robust Undo and Redo feature. Undo allows you to reverse changes that you’ve 

made to your NoteFiler database and Redo allows you to reincorporate changes if you undo a change by 

mistake. 

NoteFiler will allow you to undo the following: 

 Creating Articles 

 Deleting Articles 

 Pasting Articles 

 Duplicating Articles 

 Moving Articles to a different location in the hierarchy 

 Copying Articles to a different location in the hierarchy 

 Editing Contents (or templates) 

 Replace (as part of Find and Replace) 

 Replace All (as part of Find and Replace) 

 Adding a template 

 Deleting a template 

 Editing a template 

 Attaching a template 

 Detaching a template 

 More… 

To undo a change, just choose Edit>Undo. (Keyboard shortcut: Ctrl+Z) 

To Redo a change, choose Edit>Redo. (Keyboard shortcut: Ctrl+Y) 

Notes 

 NoteFiler will allow you to undo changes made to templates including adding, deleting, and 

modifying templates. However, you must exit the Template Manager before you can use the 

Undo function to do so. 

 Redo is not available when you’re editing text in the Contents Editor or in a field of a Template. 
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Chapter 

16 
Managing NoteFiler Databases 

Creating a New Database 

Each time you wish to start a new filing project you will need to create a new database file. 

Creating a New Database 

1. Select File>New or click the  toolbar icon. A file selection dialog box will be displayed. 

2. Enter a filename for the new database in the File Name text box. 

3. Click OK. The new database will be created and opened ready for data entry. 

Notes 

If a database is already open, a new instance of Filer will be created to open the new database so that 

you will now have two Filer databases open. If you do not want two databases open, close the currently 

open database before creating the other. 

If you use the file selection dialog to move to a different folder before creating a new database, the folder 

will be remembered and will be the default folder the next time you use the New command. 

Opening an Existing Database 

Opening an Existing Database 

1. Choose File>Open or click the  toolbar icon. A file selection dialog box will appear. 

2. Select the database you wish to open. 

3. Click OK. 

Notes 

If a database is already open, a new instance of Filer will be created to open the chosen file so that you 

will now have two Filer databases open. If you do not want two databases open, close the currently open 

database before opening the other. 

If you use the file selection dialog to move to a different folder before opening a database, the folder will 

be remembered and will be the default folder the next time you use the Open command. 

Closing a Database 

To close the currently open database choose File>Close or click the  toolbar icon. If an article’s 

Contents is being edited, the changes will be saved first and then the database will be closed. 
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Compacting a Database 

As you edit your database, the database file can start to contain wasted space. This happens when you 

delete an article or edit text making its length shorter. This generally has little effect on performance 

and is usually unimportant unless you are working with a very large database. Compacting a database 

will get rid of the unused space that editing can create resulting in a smaller file on your computer’s 

hard drive. 

Compacting your Database 

To compact your database choose File>Compact. 

Tip: You can set Preferences to automatically Compact a database each time you close it. 

Deleting a Database 

You may find from time to time that you’ve created a NoteFiler database that is no longer of any use to 

you. Although you can use Window’s File Explorer to delete files you no longer want, it is better to use 

NoteFiler’s built-in Delete command since it will also (optionally) delete the associated backups and 

report file. 

Deleting a Database 

To delete a NoteFiler database, do the following: 

1. Open the NoteFiler database that you want to import data into by choosing File>Open 

2. Choose File>Import. (a file selection dialog will appear) 

3. Choose the file containing the data to be imported. 

4. Click Open. (This will delete the database.) 

Importing Data from Another Program 

Overview 

There may be times when you wish to add information from a different program to NoteFiler. NoteFiler 

can import data stored in the common tab delimited file format that virtually all database and 

spreadsheet programs can create. Tab Delimited files are plain ASCII text files where each record is 

separated from the others by carriage return linefeed pair and each field in those records is separated 

from the other with a tab character. 

What to know before you import 

Before importing a tab delimited file, it is a good idea to know exactly how the data in that file will be 

added to your database. Here is what you need to know: 

 Each line (record) in the file represents one NoteFiler article 

 The text before the first tab will be the Label of the article 

 The text after the first tab becomes the Contents of the article 

 If there is more than one tab in a record, the text after each tab will start on a newline in the 

Contents field when imported. 

 The data to be imported into the Contents of a article MUST NOT contain any carriage return or 

line feeds. If encountered during import, each CR or LF marks the start of a new record and 

therefore a new article in the database. 

 Data to be imported cannot contain formatted text such as bold, italic, or underline. 
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 All records in the file to be imported will become articles in the Cabinet listbox. 

Importing a Tab Delimited File 

To import a tab delimited file, do the following: 

1. Choose File>Import. (A file selection dialog will appear) 

2. Choose the file containing the data to be imported and click Open. (A file chooser dialog will 

appear.) 

3. Enter a name for the database that will receive the imported data. 

4. Click Save. 

If a database is currently open it will be closed prior to starting the import process. After the import is 

complete, the new database will be opened. 

Importing a Filer 2.1 Database 

To import information from a Filer 2.1 database, do the following: 

1. Choose File>Import (a file selection dialog will appear) 

2. From the File of Type list at the bottom of the dialog, choose “Filer 2.1 database (*.mdb)” 

3. If necessary, navigate to the folder containing the Filer 2.1 file to be imported. 

4. Select the desired file and click Open. (A file chooser dialog will appear.) 

5. Enter a name for the database that will receive the imported data. 

6. Click Save. 

Merging Two or More Databases Together 

There may be times when you decide that you would like to combine the contents of two or more 

separate NoteFiler databases into one central database. This is the purpose of the Merge function. 

What the Merge Command Does 

The merge command will merge all of the articles in a file you specify with the one that is currently 

open. As part of the process, the merge command makes sure that duplicate items are excluded from the 

import and that Items that have the same label, but different contents are included and identified as 

being different so that you can decide what to do with those articles. 

What You Should Know 

If the database that you’re merging contains links, NoteFiler will be able to update those links to 

maintain proper linking in most cases. However, it is possible, though unlikely, that you could have two 

completely identical articles that have identical links (the link IDs are the same), that link to different 

articles. If this rare case occurs, those articles that are merged will all link to the articles in the original 

database rather than the articles that were in the database being merged. 

To Merge Two or More Databases Together 

1. Open the master database (the database to merge data into). 

2. Choose File>Merge. A file selection dialog box will be displayed asking you what file you wish to 

merge into the currently open database. 
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3. Select the file to merge. 

4. Click Merge. NoteFiler will merge the selected file into the currently open database. 

5. Repeat steps 2 – 4 for each additional database to be merged. 

Opening a Recently Opened Database 

NoteFiler keeps track of the nine most recently opened Databases so that you can quickly open them. 

The nine most recently opened Databases are listed at the bottom of the File menu just before the Exit 

menu item. They are numbered 1 through 9. These Databases can be opened by choosing File plus the 

desired database. 

Renaming a Database 

You may find it desirable to change the name of an existing database. Although you could rename the 

database using Window’s File Manager or Explorer, it is better to use NoteFiler's built-in rename 

function since it will also rename your report file, if one exists, and any backup files that are in the same 

folder. 

Renaming a database 

To rename a NoteFiler database, do the following: 

1. Choose File>Rename. A file selection dialog box will appear. 

2. Select the database to rename. 

3. Click OK. A dialog box will appear asking for the new name. 

4. Enter new filename. 

5. Click OK. 

The database and all related files will be renamed. 

Saving a NoteFiler Database 

In general, there is no need for you to use the Save command because, with the exception of changes 

made while editing an article’s contents, all changes are saved immediately. Changes to contents are 

saved when you move to a different article or close the database or the program. If you’re in the middle 

of an extensive edit of an article’s contents, you can force NoteFiler to save those changes immediately by 

pressing Ctrl+S or choosing File>Save. 

Saving a Database under a Different Name (Save As) 

If you want to create a copy of the current database using a different name, you can use the Save As 

function. 

Saving a database under a Different Name 

1. Choose File>Save As. A file selection dialog box will appear. 

2. Enter a name for the new database. 

3. Click OK. 

NoteFiler will save a copy of the current database under the new name and will make the new database 

the current database. 
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Chapter 

17 
Backup and Restore 

Backing up a Database 

Backing up your NoteFiler database will help protect you from data loss due to unexpected problems 

such as power loss and a hard drive error. NoteFiler can be configured to automatically backup after 

a given number of minutes during data entry and we highly recommend that you do so. However, 

you can also backup at any point in time by using the Backup command.  

To Back Up the Currently Open Database 

To back up the currently open database, do the following: 

1. Choose File>Backup or click the  toolbar icon. A file selection dialog box will appear. 

2. Enter a name for the backup file. The default name is the same name as your currently open 

database with a date and time stamp added. 

3. If desired, specify a different drive and directory for the backup to be placed in. 

4. Click Backup. 

Note 

 By default, NoteFiler backups are placed in a folder named “NoteFilerBackups”. This folder is a 

subfolder of the folder containing the NoteFiler database being backed up. 

 NoteFiler will remember the most recently used path for a backup so that the next time you use 

this function you may be able to simply click OK to perform the backup. 

How to Backup and How Not to Backup 

Unfortunately, some NoteFiler users don’t realize just how bad a loss of data can be for them until it is 

too late. What would you do if the hard drive on your computer went bad and all of your work for the last 

week was lost? What would you do if you accidentally deleted your own database? What would you do if 

there were a power failure that corrupted your computer’s hard drive? 

Over the years, SKY Software has determined some bad habits that get NoteFiler users into trouble 

when backing up their Databases. Since we’d like your filing experience to be as positive as possible, 

below are a few bad habits and good habits for you to consider. 

Bad Backup Habits 

 Not backing up at all – This is unforgivable. Anyone who depends on information that is 

stored on their computer for their livelihood must have a good backup strategy and must backup 

often. Hopefully it will not take the loss of two weeks of work at the end of a grueling schedule 
and with a customer waiting for the finished product to get you to backup your Databases. You 

must backup your Databases!!! 
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 Not backing up to external storage – If you have important data stored on your computer, 

this is truly inexcusable. The only way to be certain you’re valuable information will be available 

if your computer experiences some kind of catastrophic problem is to have the entire contents of 

your computer’s hard drive backed up to external storage. This could be an external hard drive, 

external server or a cloud based backup service. Please note that even though NoteFiler will 

automatically backup your NoteFiler databases to your internal hard drive, those backups will 

not be available if your computer’s hard drive goes bad and you have not backed up to external 

storage. 

 Backing up using the Save As command – The Save As command changes either the name 

of the current database, the location, or both. After you use the Save As command, the current 

file is now the one you ‘Saved As’ and not the original file you were working with. If you fail to 

re-open the original, you’re almost guaranteed to become confused and, at some point, the file 

you think you’ve been using will appear to have lost the last two or three days of work. Although 

there are justifiable reasons for using the Save As command, backing up should not be one of 

them. The Save As command is the single most likely way to cause backup confusion. Please 

don’t use it! 

 Saving a database under two or more names – Although using different names for a backup 

is an acceptable practice, saving the database you’re working on under different names as 

anything other than a backup is not. It will likely lead to confusion at some point. If you need to 

flag a certain point in time where you’ve made a big change to your database, do so with a 

backup, not using Save As. 

Good Backup Habits 

 Backup Frequently Using the Backup Command – NoteFiler’s built-in backup command is 

designed to help you create useful backups and to be able to go back in time by using a 

timestamp. When you use the Backup command, NoteFiler will automatically add a timestamp 

to the filename that has minute resolution. The backups cannot be opened directly; they must be 

restored using the Restore command. This prevents you from accidentally editing the contents of 

the backup. The best way to do this is to configure NoteFiler to backup your database 

automatically. 

 If you want to be sure to be able to find a particular version of a database later 

because of a big change or other reason, do not use Save As – In a case like this, append a 

note to the filename of a backup and keep the timestamp. 

 Make sure the Documents folder on your computer is backed up daily and that your 

entire computer is backed up at least once a month – All versions of Windows include 

software that can backup your Documents folder on a schedule. Some include software that will 

back up the entire computer. Depending on the version of Windows you have, you may need to 

buy a third party program to backup your entire computer. Most external hard drives include 

backup software. Consult the Windows’ Help system for information on setting up a backup 

schedule. 

Options 

See also: Restoring a Database from a Backup 

Restoring a Database from a Backup 

If your database becomes unreadable due to a power outage or hardware problem, you can restore the 

most recent backup of your database by using the Restore function. 

Notes 
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 You can only restore to a file that already exists. If you want to use the Restore feature to restore 

to a database that does not exist, you must first create the new database using File>New and 

then use the Restore feature. 

 This function will erase everything in the current database before restoring from the backup. 

 By default, Filer will display only backup files that match the name of the currently open file. If 

you want to restore from a different backup, clear the filename area of the file selection dialog, ‘*’ 

(an asterisk without the quotes) and press enter on your keyboard. 

To restore a database from a saved backup, do the following: 

1. Choose File>Restore. You will be shown a notice that all current contents will be erased. 

2. Click Yes. (A file selection dialog box will appear.) 

3. Select the backup to restore your database from. 

4. Click OK. The current contents of the database will be erased and it will be filled with the 

contents of the backup file. 

See also: Backing up a Database 
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Chapter 

18 
Working with Templates 

What Are Templates? 

Templates, quite simply are a way of defining fields for a NoteFiler article. These fields have 

properties/attributes that affect both data entry and the layout of reports you create for articles that use 

the template. 

As an example of how templates can help you create better organized NoteFiler articles, consider this 

example. Let’s assume you’re using NoteFiler to keep track of your recipes. There are several specific 

things you will probably want to include for each recipe. For instance, you probably want to know how 

long it takes to prepare, how long it takes to cook, how well you like the recipe (a rating), ingredients, 

and instructions. You’re probably going to want to be sure that all of this information is included for 

every recipe and you probably also want this information formatted in a consistent way. If you create a 

template that includes all of those fields, you will be presented with blank labeled fields in the Contents 

area that you fill in. Being able to see the required fields removes the need to remember what 

information to include for the recipe. In addition, NoteFiler gives you significant control over how the 

field titles and field contents are presented in reports. 

Once you’ve defined (created) a template. All you have to do to use it is ‘attach’ it to an article. NoteFiler 

provides for a way to automatically attach a template to the children of article, too. This makes using 

templates easy. 

It is also easy to add, remove, and edit the fields of a template. Even after you’ve added articles to yoru 

database that use the template. 

Although NoteFiler includes some sample templates that you can choose from, you may wish to read the 

information in Chapter 19 on Managing Templates which will allow you to create your own templates 

and modify existing templates. 

Attaching/Detaching Templates from an Article 

By default, every article you create has a free-form contents area. If you want an article to use a 

template you create, you must attach the template to the article. You can do this manually, one at a 

time, or you can have templates attached automatically. Here we tell you how manually attach (or 

detach) a template to an article. 

Attaching a Template to an Article 

If you want to use a template for an article, you must tell NoteFiler what template to use by ‘attaching’ it 

to the article. After you’ve attached the template, NoteFiler will display all of the appropriate fields in 

the Contents area. To attach a template to an article, do the following: 

1. Locate and select the article you want to attach a template to. In other words, make it the 

current article. 



84    NoteFiler 4.0 User’s Guide 

2. From the Templates menu, choose “Attach template to current article”. A list of available 

templates will appear. 

3. Choose the desired template and click OK. 

The Contents area of the current article will immediately change to show the fields of the attached 

template. Any existing contents text for the article will be placed in the Default Field which is defined 

with the Template Editor. 

Detaching (removing) a Template from an Article 

If you decide that you would prefer to revert to a normal Contents for a particular article, this can be 

accomplished very easily by doing the following: 

1. Choose the article to detach the template from. (Make it current) 

2. From the Templates menu, choose “Detach template from current article”. A confirmation dialog 

will appear. 

3. Click OK. 

All of the fields in the template will be combined into one field and will become the new Contents field of 

the article. Each of the template field names will appear on a new line and will be followed by a colon 

and a space. 

Attaching/Detaching Templates from all Articles in the Current List 

This is the same as attaching a template to the current article except that all articles in the list that 

contains the currently selected article will have the template attached. 

Attaching a Template to all Articles in the Current List 

To attach a template to all articles in the current list, do the following: 

1. From the Templates menu, choose “Attach template to all”. A list of available templates will 

appear. 

2. Choose the desired template and click OK. 

The template will be attached to all articles in the current list and the Contents Editor will change to 

show the fields of the attached template. Any existing contents text for the articles will be placed in the 

Default Field which is defined with the Template Editor. 

Detaching (removing) a Template from an Article 

To detach a template from all articles in the current list, do the following: 

1. From the Templates menu, choose “Detach template from all”. A dialog asking you to confirm 

you with to detach the templates from all articles in the list will appear. 

2. Click OK. 

The templates will be detached from all articles in the current list and the Contents Editor will change 

to show a standard (non-template) contents. The names of each field in the template for each article will 

remain in the Contents, but there will no longer be any actual fields. 

Automatic attachment of a Template to New Articles 

Because of the nature of templates, you are very likely to want all of the children of an article to have a 

particular template attached. Using the recipe example again, you would probably want all children of a 

Drawer labeled “Desserts” to have a recipe template attached. It is very easy to accomplish this and it is 

just as easy to stop NoteFiler from automatically attaching a template as well. 
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Attach a Template to be used for all Children of an Article 

To specify a template to be used for all children of an article, do the following: 

1. Choose the desired article. 

2. From the Templates menu, choose “Attach template for all children of current article”. A dialog 

will appear with a list of templates to choose from. 

3. Select the desired template. 

4. Click OK 

Note 

You will only be able to choose from templates that have been attached to at least one article in the 

current NoteFiler database. 

Changing Back to Creating Plain Contents for all Children of an Article  

If you should decide that you’d prefer to attach templates manually for children of an article that has a 

template specified for all children, you can do the following: 

1. Choose the desired article. 

2. From the Templates menu, choose “Detach template for all children”. A dialog will appear asking 

for confirmation. 

3. Click OK 

This will not change the attached template for any of the children of the current article. It only instructs 

NoteFiler to no longer attach a template automatically. 
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Chapter 

19 
The Template Manager 

Managing Templates (adding/editing/deleting) 

Although NoteFiler includes a number of templates for you to choose from, you will likely wish to create 

your own templates or modify the ones that we’ve included for you. The Template Manager allows you to 

do this. 

 

 

Template Manager 
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Creating a New Template 

To create a new template, do the following: 

1. Choose Templates>Manage Templates. 

2. Click New. A dialog will appear asking you for the name of the new template. 

3. Enter a name for the new template. 

4. Click OK to accept the name you’ve typed. 

5. Click Close to close the Template Manager 

Notes 

 You will probably want to edit the template after you’ve created it. See ‘Modifying a Template’ 

(below) for instructions on how to edit your new template. 

 All new templates are placed in the Global Template database. 

Modifying a Template 

If you wish to modify an existing template, do the following: 

1. Choose Templates>Manage Templates. 

2. Select the Template you wish to modify from the list of templates displayed. 

3. Click Edit or double click on the Template in the template list to bring up the Template Editor. 

4. Make changes to the template as desired. 

5. Click OK to save the changes to the template. 

6. Click Close to close the Template Manager. 

Notes 

 Templates that are stored in the Global Template database are indicated with a trailing ‘(G)’. All 

other templates are embedded within the currently open NoteFiler database. 

 The Template Editor is discussed in detail in the next chapter. 

Deleting a Template 

To delete an existing template, do the following: 

1. Choose Templates>Manage Templates. 

2. Select the Template you wish to delete from the list of templates displayed. 

3. Click Delete. A confirmation dialog will appear. 

4. Click OK to confirm you wish to delete the template. 

5. Click Close to close the Template Manager. 

Renaming a Template 

To rename an existing template, do the following: 

1. Choose Templates>Manage Templates 

2. Select the Template you wish to rename from the list of templates displayed. 

3. Click Rename. A dialog will appear asking you to enter the new name. 

4. Type the new name. 

5. Click OK to rename the template. 

6. Click Close to close the Template Manager 
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Duplicating a Template 

You may find that you want to create a new template that is similar to an already existing template. In 

this case you can duplicate the already existing template and then rename it and edit it to reflect the 

fields that you want. 

To duplicate an existing template, do the following: 

1. Choose Templates>Manage Templates 

2. Select the Template you wish to duplicate from the list of templates displayed. 

3. Click the Duplicate button. The template will be duplicated and will appear with “_Copy” 

appended to its name. 

You may now rename and edit the new template. 
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Chapter 

20 
The Template Editor 

Overview 

If you use templates with your articles, you will inevitably wish to modify the properties of the fields in 

those templates to customize how your reports look and to define what kinds of text your template fields 

will allow. The Template Editor allows you to edit the properties of existing fields and to add, rename or 

delete fields. 

 

 

Template Editor 

Note: This dialog can be resized to see more field properties at once. 
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Creating a New Field 

To create a new field, do the following: 

1. Click New. A dialog will appear asking you for the name of the new field. 

2. Enter a name for the new field. 

3. Click OK to accept the name you’ve typed. 

Notes 

 The new field’s Title will automatically be set the name of the field that you create. This is 

normally what you want, but if you want the Title that appears in a report to be different than 

the name of the field, you can change the Title (see Modifying the Properties of Fields, below). 

 Be sure to set up the new field’s properties as desired after creating it. 

Deleting a Field 

To delete an existing field, do the following: 

1. Select (click on) the field you wish to delete. 

2. Click Delete Field. A confirmation dialog will appear. 

3. Click OK to confirm you wish to delete the field. 

Deleted fields will still appear in the list of fields, but will be displayed with a line through the middle of 

the field’s name. The exception to this is that if you add a new field and then choose to delete the new 

field, that field will simply be removed from the list of fields in the Template Editor. 

Notes 

 You cannot delete all fields. There must always be at least one field remaining. If you wish to 

delete all fields, delete the entire template using the Template Manager. 

 When you close the Template Editor and you have deleted one or more fields, you will be asked 

how to handle any text within the deleted field(s). Your options will be to permanently discard 

the text or to append the text to one of the remaining fields in the template. 

Restoring a Deleted Field 

To restore a field you previously marked for deletion, do the following: 

1. Select (click on) the field you wish to restore. 

2. Click Restore Field. 

Renaming a Field 

To rename an existing field, do the following: 

1. Select the field you wish to rename from the list of fields displayed. 

2. Click Rename. A dialog will appear asking you to enter the new name. 

3. Type the new name. 

4. Click OK to rename the field. 

Changing the Default Field 

Each template you create must include a default field. This default field is used for any text added to 

Contents that has a template attached and the destination field is unknown. For instance, if you create a 

new article using drag and drop, and the article has a template; NoteFiler will not know what field to 

place the dropped text into. In this case, the default field will be used. 
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To change the default field, do the following: 

1. Click the Choose Default Field button. (A dialog will appear to let you choose the default field.) 

2. Click on the field that you wish to be the new default field. 

3. Click OK. 

Modifying the Properties of Fields 

The properties are divided into three categories: Title, Body Text, and General. The Template Editor 

distinguishes between the different properties by changing the background color. The properties that 

apply to the field’s title are shown with a beige background, those for Body Text with a lavender 

background and those that are general properties are shown with a moccasin background. 

Each Field of a NoteFiler Template includes the following properties: 

 

Title: This is what will appear as a title when you generate a report. By default it is 

the same as the field name. You can change it if you wish to have a title other 

than what is allowed for a field name. 

Show Title: TRUE/FALSE (Default=TRUE) Determines if the field name itself appears in 

a report. 

Title Font: Any valid font name (Default=<empty>) This parameter specifies the font used 

for the field’s Title. It does not affect the font used for the body text of the field. 

NOTE: if not specified, the default font is used. 

Title Font 

Size: 

A number from 0 to 9 (Default =0). Adjusts the size of the Title for this field. 

You can increase the normal font size by up to nine points. 

Bold: TRUE/FALSE (Default=TRUE) If TRUE, the field’s Title will be shown in bold 

style. 

Italic: TRUE/FALSE (Default=FALSE) If TRUE, the field’s Title will be shown in 

italic style. 

Underline: TRUE/FALSE (Default=FALSE) If TRUE, the field’s Title will be shown in 

underline style. 

Space Before: When generating a report, specifies the amount of blank space that will appear 

before the field’s Title in inches (Default=0.1) NOTE: For the first field to 

print in a template, if there is a conflict between this setting and the Report 

Options setting for Space Before Contents, the Report Options setting takes 

precedence over this one. Also note that if the Hide if Empty option is set for 

the first field of a template, that field may not always be the first field to ‘print’ 

in a report. 

Space After: When generating a report, specifies the amount of blank space that will appear 

after the field’s Title in inches (Default=0.1) (NOTE: This property has no 

effect if the Text Follows property is set to TRUE.) 

Text Follows: TRUE/FALSE (Default = TRUE) If TRUE, any text in this field will directly 

follow the Field’s name (if shown). If FALSE, the text will start on a new line 

following the FieldName. 

Body Font 

Size: 

A number from 0 to 9 (Default =0). Adjusts the size of the text for this field. 

You can increase the normal font size by up to nine points. 
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Allow Styled 

Text: 

TRUE/FALSE (Default=FALSE). If TRUE, this field will allow the use of 

formatted text including bold, italic, underline and hyperlinks to websites. 

Default 

Value: 

Defines the initial value of the field. (Default=<nothing>). 

NOTE: If you’re creating a default value for a multiline field, you can include 

“\n” in the default value text to cause text after the \n to start on a new line. 

The “\n” will not appear in the resulting text. 

Multiline: TRUE/FALSE (Default=FALSE). If TRUE, this field will allow entry of 

multiple lines of text. Otherwise, you will only be able to enter a single line of 

text. 

Body Indent: Allows you to increase the indention of the field’s text more than the value 

that has been set in Report Options. Whatever value you enter here is added 

to the value in Report Options. NOTE: This does not affect the indention of 

the field’s Title. 

Hide if 

Empty: 

TRUE/FALSE (Default=FALSE) If this field is empty, the field’s Title will not 

appear in a report and no empty line will appear for the body text if the Text 

Follows option is not checked. 

 

Tips 

 Use the Space Before property to add some white space between fields in a generated report. 

 Use the Space After property to add white space between the field’s Title and the field’s Body 

Text. 
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Chapter 

21 
Choosing your Preferences 

Overview 

Preferences are settings that affect all NoteFiler databases. Not just the one that is currently open. 

 

 
Preferences Dialog 
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Preferences 

Changing your Preferences 

To change preferences, do the following: 

1. Choose Edit>Preferences. 

2. Set your options as desired. (see below) 

3. Click OK. 

Preference Options 

Program Font 

Font – Specifies the font that you wish to use for data entry in NoteFiler. 

Font Size – Specifies the font size that you wish to use for data entry in NoteFiler. 

Use Report Options Font and Font Size for Contents – If checked, when you create a new article, 

the Contents editor will start with the font and font size specified for Contents in Report Options. 

Otherwise, the Contents editor will start with the Font and Font Size you have specified in the 

Preferences dialog. Checking this option can be useful if you use tabs in the Contents field since how 

those tabs align is affected by both font and font size and checking this option will help ensure that 

what you see on-screen is what you will see in the generated report. You should also consider the 

“Enforce font size and name” option in the Report Options dialog for Contents since even if you 

manually change the font or font size of contents, reports will be generated with the size you 

specified in Report Options. Note: This option only sets the ‘starting’ font and font size. You are free 

to change the font and font size as desired. 

Backups 

Backup database every time it is closed – If checked, NoteFiler will backup your database every 

time you close it. This option obeys the number of backups specified in the “Number of backups to 

keep” option below. 

Backup every __ minutes while database is open – If checked, NoteFiler will automatically backup 

your database after the number of minutes specified elapses. We recommend that you do not set this 

number too low especially if your database is very large. 

Number of backups to keep – Specifies how many total backups NoteFiler will keep on your hard 

drive. When backing up your database, older backups will be removed to ensure that the total 

number of backups does not exceed this number. 

Options (On/Off) 

Automatically open last file – If checked, NoteFiler will automatically reopen the database that you 

were working with the last time you had NoteFiler open. 

Show text with toolbar icons – If checked, NoteFiler will show text below the toolbar icons that 

describe the icon’s function. 

Compact database when closed – If checked, NoteFiler will compact your database when it is closed. 

Compacting gets rid of unused space that occurs when editing a database making the database as 

small as it can be. Although compacting usually rather fast, if you have a very large database with 

many pictures and/or embedded objects, it can take a long time. 

Display Contents at bottom of screen – If checked, The Contents of articles will be displayed at the 



 Choosing your Preferences 97 

bottom of the NoteFiler screen instead of on the right-hand side. This increases the width of the 

contents. For certain types of material, this layout may be preferable to the default setting of 

displaying the Contents on the right side of the screen. 

Enable listbox tooltips – If checked and if you let your mouse cursor hover over a listbox item, a tool 

tip will pop up showing the whole Label. This is useful if you tend to use very large labels since it 

would not be uncommon for part of the label to be hidden. 

Multiline template fields capture tabs – If checked and if you’re editing contents in either a plain 

contents or within the fields of a template, if you press tab, the tab will be entered as part of your 

text rather than taking you to the next control. If this option is not checked, pressing tab will take 

you to the next template field. In this case, if you want to type a tab into your field text, you must 

press Ctrl+Tab instead of just Tab. 

Overwrite reports without asking for confirmation – If checked, when you generate a report, you 

will not be asked if you want to overwrite the report if it already exists. The report will be 

overwritten with the new report without notifying you. 

Options (Other) 

Visible lines in multiline template textboxes – Determines the height of the multiline textboxes 

when templates are displayed in the Contents area. The height of the textboxes will be determined 

by how many lines of text you wish to be visible. The minimum is 2 and the maximum is 15. This 

setting has no effect on normal textboxes are on single line textboxes in templates. 

Color Theme 

Theme – Allows you to choose from the available color themes. If you choose ‘<custom>’ you’ll be able to 

create your own color theme using the current theme as a starting point. When you choose ‘<custom>’ 

the Theme Designer dialog will appear. That dialog is described in the section ‘Designing your Own 

Color Theme. 

Designing your Own Color Theme 
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Theme Designer dialog 

The Theme Designer dialog allows you create your own custom color theme for NoteFiler. You’ll be 

starting with the theme that is currently active in NoteFiler and you can either customize certain parts 

of that theme or you can start by changing the Base Color and then tweaking the colors of the different 

elements of the NoteFiler user interface to your personal tastes. Below we provide information on how to 

design your own custom color theme. 

Hue, Saturation, and Luminance 

When you’re adjusting the colors in your theme you’ll be using three attributes – Hue, Saturation, and 

Luminance. These attributes affect your colors in the following ways. 

Hue – Defines the color of the element. The range is 0-240. 

Saturation – Defines how strongly the color permeates the color you’re defining. The range is 0-249. A 

saturation of 0 indicates that the color does not appear at all and will result in black. 1 will result in gray 

and any value higher than that will include at least some of the base color or ‘hue’. 

Luminance – Defines how bright the color is. The range is 0-240. 0 will result in black and 240 will 

result in the full strength of the color being displayed. 

Options 

Color group – One of four groupings of control elements to make it easier to configure your color theme. 

The four groups are described in the next section. 

Base Color – This defines what the themes main color is. The range is 0-240 and describes a color circle 

where the ends meet back at the same color. Therefore, color 240 would be the same as color 0. Color 0 

represents full Red and colors 1 and 240 are very close to red but not exactly red each has a slightly 

different tint because they are on opposite sides of the circle. The color wheel starts with red and goes 

through yellow, green, cyan, blue, purple, and back to red. This represents the color’s Hue. 

The user interface (UI) elements are categorized into four groups: 

Dialog Colors – defines the background color of configuration dialogs and also the background color of 

the two areas of the main NoteFiler screen (one has the listboxes and the other contains the 

Contents Editor). Your options are: 

Dialog – This defines the background color used for configuration dialogs and for the split area of 

the main program screen. 

Dialog 2 – This is the color used for the background of tab sheets on a configuration dialog. 

Groups – The background color used in group boxes in a configuration dialog. An example is 

included in the Theme Changer dialog. 

Border Colors – defines the color used for the border of UI controls. Your options are: 

Normal – The color of a control border unless the control is disabled or has focus. 

Disabled – The color of a control’s border if the control has been disabled. (Normally gray) 

With Focus – The color of a control’s border if the control currently has focus. (This color is 

currently not supported) 

Button/Control Face Colors – defines the colors used for the face of button controls and for 

checkboxes and radio buttons. Your options are: 

Button normal – The color that a button’s face has when the button is enabled. 

Button, disabled – The color that a button’s face has when the button is disabled. 
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Btn, mouse over – The color that a button’s face has when the mouse cursor is over the button. 

Btn, mouse down – The color that a button’s face has when the left mouse button is currently being 

held down on the button. 

Ctrl, mouse over – The color that a checkbox or radio button face has when the mouse cursor is 

over the it. 

Ctrl, mouse down – The color that a checkbox or radio button face has when the left mouse button 

is being held down on it. 

Text Colors – defines the colors used to display text. Your options are: 

Normal – The color of text for a textbox and for the labels of other controls when the control is 

enabled. 

Disabled – The color of text for a textbox and for the labels of other controls when the control is 

disabled. 

Background – The color for the background of text in a textbox. Does not affect control labels. 

Bckgrnd, disabled – The color for the background of text in a textbox when the textbox has been 

disabled. Does not affect control labels. 

Notes 

 The normal face color of a checkbox or radio button is the same color that has been specified for 

the background color for text. 

 Although it is possible to have different hues for different UI elements, this will generally result 

in an unpleasant color theme. There are exceptions to every rule, however. 

  

Saving your Color Theme 

To save your theme, click Save Theme. This will present a dialog asking you to specify a name for your 

color theme. You can type a new name or you can select one of the existing themes if you wish to 

overwrite the existing theme with your modifications. (Please note that you cannot overwrite one of the 

preset themes that come with NoteFiler.) 
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Dialog for specifying your color theme’s name 

When you type a name into the in the textbox, NoteFiler will automatically select any existing theme 

that matches your typing so far in the list of existing themes below the textbox. If you continue to type 

and what you’ve typed stops matching an existing theme, NoteFiler will unselect the theme that was 

selected in the list of existing themes. 

When you’ve typed or selected your desired theme name, click OK to save or overwrite the theme. If you 

change your mind and decide you don’t want to save the theme, click Cancel. 
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Appendix 

A 
Support 

 

Overview 

Support for NoteFiler is provided through our NoteFiler Support System which is a collection of forums 

related to NoteFiler. This system allows other NoteFiler users to help new users with “how to” questions 

and with anything else related to NoteFiler. 

Please note that although we encourage an open forum where all opinions can be expressed, we will not 

tolerate obnoxious or profanity laced posts. Those posts will be removed and the offender may be 

prohibited from posting anything in the future. Posts to the forums may or may not be moderated at the 

discretion of our support staff. Please keep in mind that there can be customers of any age on these 

forums and word your queries or statements appropriately. 

The NoteFiler Support System 

What is the NoteFiler Support System? 

The NoteFiler Support System (NSS) is a combination of two services. The first is a feedback system that 

allows you to report problems you may encounter while using your program. This might be a simple 

documentation error or a malfunction of the program. The second is a collection of forums where 

customers can create queries to find answers to questions from other NoteFiler owners. It is also a place 

where customers can make feature suggestions for future releases of the program. Because NoteFiler is 

a new program, the forums will take awhile to fill with useful information. However, as more and more 

queries are posted and more and more questions are answered, the forums will become very useful since 

they can be searched to make it relatively easy to find answers to questions. 

We highly recommend that you create a NSS account because it is a great way to learn about NoteFiler 

and to share your own expertise. 

How do I create an account? 

To create an account, enter the link below in your Internet browser. 

http://www.forums.notefiler.com/ 

 In the resulting web page, click the Login button which will lead to a page that will allow you to create a 

new account. Creation of the account requires validation of your email address and we may also require 

a moderator’s approval. 

How do I ask a question? 

To ask a question, login to your account and then click on the Forums link at the top of the web page. 

Then click on the Forums Map link, choose the forum that most closely matches the nature of your 

http://www.forums.notefiler.com/
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question and then, after searching the forum to make sure the question has not already been answered, 

click on the Submit a Query to this forum button. 

Who do I contact if I have a problem creating an account? 

If you have a problem creating your account, please write to sales@notefiler.com and be sure to include a 

detailed description of the problem you are having. 

 

mailto:sales@notefiler.com
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Appendix 

B 
Keyboard Shortcuts 

Shortcuts Listed by Keycap and Modifier 

Ctrl Key Shortcuts 

Shortcut Function 

Ctrl+A Select All 

Ctrl+B Toggle bold 

Ctrl+C Copy current article with children 

Ctrl+D Duplicate current article with children 

Ctrl+E Center justify paragraph 

Ctrl+F Find All 

Ctrl+G Move To Again 

Ctrl+H Find and Replace 

Ctrl+I Toggle italic 

Ctrl+J Create new article (at current level) 

Ctrl+L Left justify paragraph 

Ctrl+M Move To 

Ctrl+N New NoteFiler database 

Ctrl+O Open  

Ctrl+P Print (Starts Report Wizard) 

Ctrl+Q Quit (application) 

Ctrl+R Right justify paragraph 

Ctrl+T Copy To 

Ctrl+U Toggle underline 

Ctrl+V Paste 

Ctrl+W Close current NoteFiler database 

Ctrl+X Cut 

Ctrl+Y Redo 

Ctrl+Z Undo 

Continued on the next page… 
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Ctrl Key Shortcuts (continued) 

Ctrl+0 Give focus to Contents/Template 

Ctrl+1 Give focus to Cabinet listbox 

Ctrl+2 Give focus to Drawer listbox 

Ctrl+3 Give focus to Folder listbox 

Ctrl+4 Give focus to Item listbox 

Ctrl+[ Reduce font size by one point 

Ctrl+] Increase font size by one point 

Ctrl+Shift+B Toggle Subscript 

Ctrl+Shift+C Copy current article without children 

Ctrl+Shift+D Duplicate current article without children 

Ctrl+Shift+F Set Font (name and/or size) 

Ctrl+Shift+L Toggle bulleted text 

Ctrl+Shift+O Font Color 

Ctrl+Shift+P Set paragraphs indents (Left, Right, and Hanging 

indent) 

Ctrl+Shift+R Clear all font attributes (Reset to defaults) 

Ctrl+Shift+T Toggle Strikeout 

Ctrl+Shift+U Toggle Superscript 

Function Keys 
 

Shortcut Function 

F1 Help 

F2 Edit Label of Current Article 

Alt Key Shortcuts 
 

Shortcut Function 

Alt+E Open Edit Menu 

Alt+F Open File Menu 

Alt+S Open Search Menu 

Alt+H Open Help Menu 

Alt+O Open Format Menu 

Alt+R Open Report Menu 

Alt+T Open Templates Menu 

Alt+F4 Closes NoteFiler 
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Shortcuts by Function 

Working with Database Files 

 

Description Shortcut 

Create a New NoteFiler database Ctrl+N 

Open an existing NoteFiler database Ctrl+O 

Close the currently open NoteFiler database Ctrl+W 

Print (generates a report using the Report Wizard) Ctrl+P 

Working with the Windows Clipboard (text or articles) 
 

Description Shortcut 

Copy currently selected text (or currently selected article w/children) Ctrl+C 

Cut currently selected text (or currently selected article and children) Ctrl+X 

Delete currently selected text (or currently selected article and 

children) 

Del 

Paste text or article Ctrl+V 

Copy currently selected article without its children Ctrl+Shift+C 

Select All Ctrl+A 

Formatting Text (working with the Contents Editor) 
 

Description Shortcut 

Toggle Bold Ctrl+B 

Toggle Italic Ctrl+I 

Toggle Underline Ctrl+U 

Toggle Strikeout Ctrl+Shift+T 

Toggle Bulleted text Ctrl+Shift+L 

Left justify paragraph Ctrl+L 

Center justify paragraph Ctrl+E 

Right justify paragraph Ctrl+R 

Increase font size by one point Ctrl+] 

Decrease font size by one point Ctrl+[ 

Clear all font attributes (Reset to defaults) Ctrl+Shift+R 

Set paragraphs indents (Left, Right, and Hanging indent) Ctrl+Shift+P 

Set Font (name and/or size) Ctrl+Shift+F 

Toggle Superscript Ctrl+Shift+U 

Toggle Subscript Ctrl+Shift+B 

Font Color Ctrl+Shift+O 
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Working with Articles 

 

Description Shortcut 

Rename (edit) the current article’s label F2, Enter 

Create a new article at the current level Ctrl+E 

Duplicate the current article with children Ctrl+D 

Duplicate the current article without children Ctrl+Shift+D 

Copy the current article and its children to a different place in the 

hierarchy 

Ctrl+T 

Move the current article and its children to a different place in the 

hierarchy 

Ctrl+M 

Repeat the last Move To command (Move To Again) Ctrl+G 

Find/Replace 
 

Description Shortcut 

Display Find All dialog Ctrl+F 

Display Find and Replace dialog Ctrl+H 

Giving Focus to a Cabinet, Drawer, Folder, Item, or Contents 
 

Description Shortcut 

Give focus to Cabinet listbox Ctrl+1 

Give focus to Drawer listbox Ctrl+2 

Give focus to Folder listbox Ctrl+3 

Give focus to Item listbox Ctrl+4 

Give focus to Contents/Template Ctrl+0 

Other 
 

Description Shortcut 

Undo Ctrl+Z 

Redo Ctrl+Y 

Close NoteFiler (Quit) Ctrl+Q 
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Appendix 

C 
The Toolbar and Status Bar 

Overview 

NoteFiler contains a toolbar that allows quick access to commonly used functions with a click of your 

mouse. There are keyboard shortcuts for everything in the toolbar, so for those who prefer to use the 

keyboard, there is still quick access to every function. 

NoteFiler also has a status bar that shows you information related to the program’s current state. It 

provides progress information for operations that take a lot of time and lets you know what templates 

are attached to the various articles in your database. 

The NoteFiler Toolbar 

The toolbar (shown below) contains many icons that allow you to perform frequently used program 

functions with a single mouse click. The toolbar is made up of five button groups. These groups are: 

 

 

The NoteFiler Toolbar 

 

Group Description 

File Functions that manipulate NoteFiler database files 

Search Functions that search the NoteFiler database for text and optionally 

replace that text with something else 

Undo/Redo Undo and Redo 

Clipboard Functions that support use of the Windows clipboard 

Article 

manipulation 

Functions that manipulate NoteFiler articles and navigate to them 

To learn what a particular toolbar button does, hold the mouse pointer over the desired button for about 

a second and a hint will appear giving a brief description of what the button's function is. 

Showing or Hiding Toolbar text 

To show or hide the text label of toolbar icons, open NoteFiler’s Preferences dialog and uncheck “Show 

Text with toolbar icons”. See Chapter 21 Choosing your NoteFiler Preferences for more information on 

NoteFiler Preferences. 

The NoteFiler Status Bar 
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The status bar (shown below) contains information about NoteFiler’s current state or ‘status’. It’s most 

basic function is to simply let you know what’s happening. For instance, when you backup a database, it 

shows you the progress of that backup and when it is finished; displays a message temporarily letting 

you know that the backup is complete. 

The status bar also lets you know the name of a template if one is attached to the current article. This is 

demonstrated in the example shown below. The template attached to the current article in this case is 

named: ‘Recipes’. In addition, if the current article has a template that will be used when creating 

children for the current article, that template is displayed also. Those will appear in the status bar as: 

“Children Tpl: template name”. 

 

 

NoteFiler Status Bar 
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Appendix 

D 
Example Databases 

Overview 

NoteFiler is an extremely flexible program that allows you to enter, track, and organize an almost 

unlimited number of things. In order to help you get started, we’ve created some example databases that 

give you an example of how to enter and organize various types of information. These example database 

include instruction to describe the philosophy of the database’s structure and use. You can use these 

database’s as-is, or you can modify them to better suit your own purposes. They are only intended to give 

you a starting point. We want your own creativity to drive the design of the final database. 

To see the available example databases, please visit this web page: 

http://www.notefiler.com/downloads/example_dbs/ 

As time passes we intend to add additional example databases for various types of information. 

 

http://www.notefiler.com/downloads/example_dbs/
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Appendix 

E 
Example Templates 

Overview 

One of NoteFiler’s biggest strengths is its flexibility.  

Example Template Descriptions 

List example templates along with a description of their intended purpose. 
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Appendix 

F 
Specifications 

Specifications 

 

Maximum size of a 

database: 

Limited only by available storage space and the file system on your 

computer. 

Maximum number of 

articles: 

Limited only by the maximum database size. 

Maximum size of an 

article’s label: 

99 characters. 

Maximum size of an 

article’s Contents: 

1 billion bytes. 

Maximum size of an 

Article: 

This is simply the combination of maximum Label size and maximum 

Contents size. 
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Appendix 

G 
Troubleshooting 

Problems and solutions 

General 

If you try a solution for a specific problem that is listed below and it does not cure the problem, try these 

general solutions for fixing a problem: 

 Close and then reopen NoteFiler. 

 Create a new, empty, database and then use the Merge command to merge the contents of the 

problem database into the new one. 

My NoteFiler database has grown huge. Can I make it smaller? 

When you delete information in your NoteFiler database, the space it consumed still remains and 

although that space may get reused as you add more information, it may result in a large amount of 

unused space. Especially if you have been adding and deleting pictures or other large amounts of data. 

You can use the Compress command (File>Compress) to remove this unused space from your NoteFiler 

database and make it as small as you can. You can even setup NoteFiler to automatically compress your 

database every time you close it by using your NoteFiler Preferences dialog. 

Problems with Templates 

 Try rebooting your computer. 

 If rebooting does not work, the database may be corrupt. Try creating a new empty database 

with a different name and then use File>File Management>Merge to merge the database entries 

from the problem database into the new database. 

Problems with Contents 

The last paragraph in a bullet list is missing the bullet 

In order for a paragraph to have the bullet attribute, there must be a paragraph break following the list 

item. If you don’t have the following paragraph break, the last paragraph in the bullet list will not have 

the bullet after the contents is saved and reloaded and will appear as a normal paragraph. 

Problems with Reports 

I’m not getting the entire report 

Be sure that you chosen ‘All’ for the Scope on the first page of the Report Wizard. You have probably 

chosen ‘Current Selection’. 



116    NoteFiler 4.0 User’s Guide 

There is extra space between two consecutive article labels or after the contents of one 
article and the label of the next article 

This is most likely caused be extra blank lines at the end of Contents text. You may even have a an 

article whose Contents appears empty, but if you click in the Contents Editor and press Ctrl+End you’ll 

see that there are blank lines in the Contents. Just delete the extra lines to fix this problem. 

Problems with Find/Replace 

The text being search for is not found, but you’re certain it exists in the database 

The Find All function is affected by the formatting of text. If a word or phrase being searched for 

contains two or more parts that have different character style attributes (any combination of these: 

plain/bold/italic/underline) the text won’t be found. The all of the text being searched for must contain 

the same character style or styles. If you have the Pro version of NoteFiler, try using the Find and 

Replace command instead of the Find All command. 
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Appendix 

H 
Glossary 

Overview 

This manual uses some terms you may not be familiar with. Below are some of the terms we think might 

be useful. If you find a term you don’t understand and would like it to be included in a future update to 

the NoteFiler User’s Guide, please log in to your NoteFiler Support Forum account and post the 

suggestion to the Documentation forum. 

Article – There are four listboxes in NoteFiler. They are named Cabinet, Drawer, Folder, and Item. 

Everything item listed within one of these listboxes is an article. There is no difference between 

a Cabinet article or an Item article other than the hierarchy level. Each NoteFiler article 

contains a Label and Contents. The label is simply a short description of the article which you 

might see as similar to the label you would put on a filing cabinet, drawer or folder. The details 

about the article are placed in the Contents. As you’ll find out later, Contents can have templates 

attached to them which can make them even more useful. However, for many, if not most, of 

your organizational needs, you’ll be able to get along without templates. Templates are discussed 

in Chapter 18 Working with Templates. 

Children – In this program, "children" are subcategories of the currently highlighted item in the list box 

above it. That highlighted item is also called the Parent. To further explain; Articles in a Drawer 

are "children" of highlighted item in the Cabinet listbox; articles in a Folder are children of the 

highlighted item in a the Drawer listbox, and Items are children of the currently highlighted 

item in the Folder listbox. 

Dialog or Dialog Box – A temporary window that appears in order to request information from you; 

after the information has been provided you generally dismiss the box with `OK' or `Cancel' 

Hyperlink – A hyperlink is a word, phrase, or image that you can click on to jump to a new document or 

a new section within the current document. Hyperlinks are found in nearly all Web pages, 

allowing users to click their way from page to page. Text hyperlinks are often blue and 

underlined, but don't have to be. When you move the cursor over a hyperlink, whether it is text 

or an image, the arrow should change to a small hand pointing at the link. When you click it, a 

new page or place in the current page will open. 

Hyperlinks, often referred to just as "links," are common in Web pages, but can be found in other 

hypertext documents. These include certain encyclopedias, glossaries, dictionaries, and other 

references that use hyperlinks. The links act the same way as they do on the Web, allowing the 

user to jump from page to page. Basically, hyperlinks allow people to browse information at 

hyperspeed 

Parent – If an article has children (see definition of children above) it can be referred to as a parent in 

addition to being referred to as an article. An article that has no children is simply an article. It is not a 

parent. 

Tree – An article plus all if it's children. 
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Index 
Note about this index: This manual will be updated over time and because of that, the index was 

embedded into the original document. It is possible that, in the future, material will be added that will 

cause some items that originally appeared on a single page to flow over two pages. Because the original 

entry would not have been entered as a range, it will not be automatically presented in the updated 

database as a discussion over two pages. If you notice this kind of problem, please let SKY Software 

know and we’ll correct the embedded entry.

An index will be written for the User's 

Guide after NoteFiler is released. It will 

appear in a program update.
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